gurgling sound from fuel pump? - Mazda MX-6 Forum
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 8-12-03, 3:02 Thread Starter
 
Join Date: Jan 2001
Location: Wisconsin, USA
Age: 33
Posts: 7,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
           
gurgling sound from fuel pump?

Ok, I just changed my fuel pump and gasket. Before I changed these parts, the pump was making a high-pitched whining sound and the gasket around it was leaking for about 15 miles after I filled the tank up to the top. Now the pump will make a low-pitched gurgling sound that cycles on/off with the car running at idle.
Do you guys think I bought a bad "new" pump? Or perhaps there is air in the fuel tank or something? I'm really stumped on this as I was very careful assembling the fuel pump assembly and the car runs just fine aside from this noise. Maybe I messed something up assembling it?? . I would think it would have running problems though if that was the case...

I'm also still smelling a bit of gas inside the car as I was when the gasket was leaking. I'm not sure if this is just residual from removing the pump earlier or if I have a leak somewhere else in the gas tank or what. I haven't filled the tank up all the way again yet as I'm letting the RTV sealant I put on the gasket dry completely.

Last edited by magik8; 8-12-03 at 3:10.
magik8 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 8-12-03, 12:45
 
Join Date: Aug 2002
Location: Fredricton
Age: 32
Posts: 1,298
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
it does seem odd that your pump is making noise, but if your car is running fine, don't worrie too much about it. Just keep an eye on it and make sure the noise dosn't get worse.

Thats my best solution, mabey someone else can give you better advice.

methman

.040" cylinder overbore, K&N filter, CAI, boost/vac & A/F gauges, 2.5" CAT back exaust (side exit), NGK V-power plugs, Federal Mugal 7mm plug wires, Bosch Disttrubitor cap & button, upper front strut bar, 10psi's, Nissan 280zx hood scoop and air vent.
Methman is offline  
post #3 of 4 (permalink) Old 8-12-03, 19:11
 
imagoonmx6's Avatar
 
Join Date: Sep 2001
Location: Chicagoland IL
Age: 34
Posts: 1,770
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 6
    
When I installed my new pump it only gurgled when I bridge the fuel pump diag connector for a few moments as it kicked all the aire out of the pump and lines. I don't think I have ever heard mine "cycle" it runs all the time and is nearly inaudiable to me. (Walbro 255 HP).

~Chris

2006 Mazdaspeed6 6-spd 274/280 stock.
Those people who think they know everything are a great annoyance to those of us who do.
-Isaac Asimov
imagoonmx6 is offline  
post #4 of 4 (permalink) Old 8-14-03, 0:32 Thread Starter
 
Join Date: Jan 2001
Location: Wisconsin, USA
Age: 33
Posts: 7,325
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
           
Well the pump isn't making the noise any more. Perhaps it was just getting the air out of the lines after the system had been open for a few hours.
magik8 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda MX-6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome