Ignition Timing. (KLZE, KL31 Ecu, JE50, DE Disty) - Page 2 - Mazda MX-6 Forum
Reply
 
LinkBack Thread Tools
post #16 of 19 (permalink) Old 7-18-09, 5:36
 
Join Date: Jun 2003
Location: kent
Age: 46
Posts: 3,601
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
      
I would guess at this point in time, you have a faulty ECU. the issue with you not being able to put it in test mode and time the engine points to it, you can throw the je50 on the car with the std ecu, you just will not be able to drive it, i'm sure it will turn over and you will find you can still put the ecu in test mode.

Gone...
Oddball is offline  
Sponsored Links
Advertisement
 
post #17 of 19 (permalink) Old 7-18-09, 13:54 Thread Starter
 
herox21's Avatar
 
Join Date: May 2007
Location: Cary
Age: 26
Posts: 384
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
Quote:
Originally Posted by Oddball View Post
I would guess at this point in time, you have a faulty ECU. the issue with you not being able to put it in test mode and time the engine points to it, you can throw the je50 on the car with the std ecu, you just will not be able to drive it, i'm sure it will turn over and you will find you can still put the ecu in test mode.
It's funny you say that....I tried doing just that. I put the KL85 ecu back in and didn't change the JE50 on purpose, just to see what would happen. It just dies out right, which is normal from what I hear.

If it truely is a faulty ECU, that's excellent as I can just buy a new ecu and je50.....however if it is a wiring issue, i'll be back to square one. I just really hope it's a crappy ECU, lol

Thanks for the help you've given thus far Oddball, you've been more than helpful sir!

The Daily: 1994 Mazda 626 Lx I4 Atx
The Project: 1995 Mazda Mx6 Ls V6 Mtx

Quote:
Originally Posted by D'sMx-6 View Post
That bitch is lower than the value of the U.S. dollar
herox21 is offline  
post #18 of 19 (permalink) Old 7-18-09, 16:18
 
Join Date: Jun 2003
Location: kent
Age: 46
Posts: 3,601
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
      
your welcome, hope you find one to 'try' before you buy

Gone...
Oddball is offline  
post #19 of 19 (permalink) Old 12-6-12, 18:16
New Member
 
Join Date: Dec 2012
Age: 20
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Have the exact same problem

I have the exact same problem except mine is stuck on 15 degrees out

i ended up having a short in the ignition system on my O2 sensors and on the wires to the alternator
Gearhead9894 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda MX-6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome