Headlight Problem...Please Help! - Mazda MX6 Forums: MX6 Forum
Mazda MX6 Forums: MX6 Forum User Control Panel
 


» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mazda MX6 Forums: MX6 Forum > 2G MX6 (93-97) > 2G MX6 General
Register Home Forum Active Topics Garage Garage Photo Gallery Arcade Mark Forums Read Auto EscrowAuto Loans

Mx6.com is the premier Mazda MX6 Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 8-5-09, 10:09   #1 (permalink)
  Total: 17 Power: 5
 
jkwaggener's Avatar
 
Join Date: Jul 2005
Location: Urbandale, IA, USA
iTrader: (0)
Headlight Problem...Please Help!

Hi, I have searched the forums and have not seen this problem listed anywhere. I have a '93 LS and my headlights stopped working. The only way to turn them on is to pull the headlight lever back (flash to pass). The parking lights and tur signals all work fine. I replaced the light/turn signal/wiper switch behind the steering wheel to no avail (they still will only turn on when the flash to pass is used. I looked at the fuse under the hood and it is also good. Am I missing out on checking some other fuse??? Please help!!!!

Thanks,

John

Speed is Life!
jkwaggener is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 8-5-09, 10:20   #2 (permalink)
  Total: 10 Power: 5
 
Join Date: Oct 2006
Location: Ingersoll, Canada
Age: 34
iTrader: (0)
I believe there is headlight relays located behind the left hand side headlight, a cluster of 3 in black rubber sleaves worth checking out...
DarkHeavens is offline   Reply With Quote
Old 8-5-09, 10:24   #3 (permalink)
  Total: 17 Power: 5
 
jkwaggener's Avatar
 
Join Date: Jul 2005
Location: Urbandale, IA, USA
iTrader: (0)
Will do, thanks!

Speed is Life!
jkwaggener is offline   Reply With Quote
Old 8-8-09, 4:32   #4 (permalink)
  Total: 194 Power: 5
 
Join Date: Aug 2005
Location: Jersey City, NJ, USA
Age: 29
iTrader: (1)
darkheavens is right. and its a bundle of TWO in black rubber sleeves. one of them is toast. $42 at mazda or cheap at a junk yard. the relays are in metal tower to the left of the battery (looking from the front of the car).

mine: 93 ZE, clutchmaster clutch, fidanza flywheel, poly motor mounts, HS CAI, HS headers, ractive exhaust, F&R strut bars, ground controls on illuminas, SS clutch line, espec heads/corners and much much more!!
hers: 93 ZE. pretty much the same mods. + F&R drilled rotors, STS, h&r's
josey_gt is offline   Reply With Quote
Old 8-22-09, 11:47   #5 (permalink)
  Total: 17 Power: 5
 
jkwaggener's Avatar
 
Join Date: Jul 2005
Location: Urbandale, IA, USA
iTrader: (0)
Can you guys tell me which one it is??????

Speed is Life!
jkwaggener is offline   Reply With Quote
Old 8-22-09, 12:04   #6 (permalink)
  Total: 128 Power: 5
 
anthrax1202's Avatar
 
Join Date: Jul 2007
Location: Mason City, IA, USA
Age: 25
iTrader: (3)
do your brights work? maybe the filiment for the low beams burned up? just something simple and easy you could check into quick...
anthrax1202 is offline   Reply With Quote
Old 8-23-09, 8:55   #7 (permalink)
  Total: 17 Power: 5
 
jkwaggener's Avatar
 
Join Date: Jul 2005
Location: Urbandale, IA, USA
iTrader: (0)
Quote:
Originally Posted by anthrax1202 View Post
do your brights work? maybe the filiment for the low beams burned up? just something simple and easy you could check into quick...
The only way they all come on is flash to pass, the headlights will not work with the headlight switch at all, only pulling on it for "flash to pass" turns them on, so all the bulbs are good.

Speed is Life!
jkwaggener is offline   Reply With Quote
Old 8-23-09, 13:31   #8 (permalink)
  Total: 17 Power: 5
 
jkwaggener's Avatar
 
Join Date: Jul 2005
Location: Urbandale, IA, USA
iTrader: (0)
There are 4 relays on the left side, three are the identicle part # and are black (covered in rubber), the forth is different, kind of red, no part # and covered with rubber, does anyone know which one it is???? Please?????

Speed is Life!
jkwaggener is offline   Reply With Quote
Old 8-25-09, 0:41   #9 (permalink)
  Total: 420 Power: 5
 
Join Date: Sep 2002
Location: Tallinn, Estonia
Age: 35
iTrader: (1)
Quote:
Originally Posted by jkwaggener View Post
The only way they all come on is flash to pass, the headlights will not work with the headlight switch at all, only pulling on it for "flash to pass" turns them on, so all the bulbs are good.
anthrax1202 can be right. When you "flash to pass", you flash highbeams. Filaments for lows may still be out which means change of bulbs may help. Or relay or light switch can also be bad. I'd bet on relay or the switch.

Mazdayasna, the worship of Mazda

Evert is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Permissions
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 3:11.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright 2000-2010, MX6.com
MX6.com is in no way affiliated to Mazda Motor Corp.
All views expressed in this site are the personal opinion of the author and not necessarily the owners of MX6.com.