Issues with my recently bought Gen 2 MX6 - Mazda MX-6 Forum
 1Likes
  • 1 Post By Teshire
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 5-25-16, 20:46 Thread Starter
New Member
 
Join Date: May 2016
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Exclamation Issues with my recently bought Gen 2 MX6

I recently bought a '92 Gen 2 Mazda MX6 2.5L V6 RHD and there are a few things broken on it. I was wondering if you guys have any clue on how to fix any of these things.
Master Power Window Switch: Everything on it works aside from the drivers side window switch. I can control the passengers side window from it but not the drivers side. When i took it apart and went probing around with my multi-meter i found that the passengers switch outputted 12V where as the drivers side only outputted 5v.
Speedometer: The speedometer doesn't show anything, it just stays on 0kmh all the time. All the other dials work aside from the odometer which i assume works on relative speed of the car.
Battery Drain: I charged the battery about a week ago, started the car once and then didn't run it for a week. When I came back to the car it unlocked and the windows all worked as normal, the next day the battery was dead. I'm sure all the lights on the inside were off and the door was shut properly.

Thanks all for reading the post this far, and any help would be greatly appreciated.
Kindly
~Teshire
Darren Tait likes this.
Teshire is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 6-19-16, 8:30
New Member
 
Join Date: Jun 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Hi Teshire, I have an MX-6 I am breaking. I could supply you with a switch and speedometer both in good working order if you are interested? Same car and same engine as yours, but mine is '95. Cheers, Darren
Darren Tait is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome