New owner of a 94' Mazda MX6 - Mazda MX-6 Forum
Reply
 
LinkBack Thread Tools
post #1 of 21 (permalink) Old 2-21-17, 11:20 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
New owner of a 94' Mazda MX6

Hello everyone,

Just few days ago my aunt gave me her Mazda MX 6 that she bought brand new in 1994. The car currently has 115k, it is a 5 speed V6 LS. Other than fading paint the car was taken care of to my aunts knowledge. All work was done at a Ford dealership with receipts saved. Now, to MY knowledge, she has done little to no work to the ignition, fuel, and air system of the engine. When I got the car and took it for a test drive, under load it has a pretty bad hesitation/stutter. Rev's fine, idles decent enough nothing crazy. So far I've replaced the plugs and the wires, still having the issue. What are some things I should look at, and maybe start replacing... it is a 23 year old car with 23 year old parts in most places.
jakobw5 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 2-22-17, 20:45
New Member
 
Join Date: Feb 2017
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Power: 0
 
I'm in a similar situation with a 93. Since I don't know the history I plan to do the timing belt and anything else that could be changed while I'm in there. It's a bit of work to get at the belt so you may as well make sure the water pump, alternator and Pully bearings. Etc
Catimann is offline  
post #3 of 21 (permalink) Old 2-23-17, 10:19 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
I did notice that the shuddering only happens between 1500rpm to about 3000 rpm. After that it seems to smooth itself out!
jakobw5 is offline  
Sponsored Links
Advertisement
 
post #4 of 21 (permalink) Old 2-23-17, 20:33
New Member
 
Join Date: Feb 2017
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Power: 0
 
Clean the MAF
Catimann is offline  
post #5 of 21 (permalink) Old 2-23-17, 22:07

 
TwoPedalWarrior's Avatar
 
Join Date: Oct 2010
Location: Victoria BC
Age: 38
Posts: 2,558
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 48 Post(s)
Power: 5
 
Quote:
Originally Posted by Catimann View Post
Clean the MAF
Silly boy, there are no maf's stock in these v6 cars.

If you've not done the cap and rotor do those, if issue still doesn't go away, its likely the distributor

1994 MX-6 LS ATX/MTX Swap
What have I done to it? Stuff... What will be done to it next? More Stuff...
Build Thread - http://www.mx6.com/forums/gallery/24...ld-thread.html
TwoPedalWarrior is offline  
post #6 of 21 (permalink) Old 2-23-17, 23:00
 
Join Date: Sep 2014
Age: 36
Posts: 153
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Power: 3
 
Garage
[quote=

if you've not done the cap and rotor do those, if issue still doesn't go away, its likely the distributor[/quote]. +1?????
MaZZZda is offline  
post #7 of 21 (permalink) Old 2-24-17, 15:39 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Yeah I'm assuming the MAF he is talking about is this....

http://images.oreillyauto.com/parts/...420063-rit.jpg

But how you go about cleaning that is besides me. I will replace the cap and rotor and update as soon as its installed.
jakobw5 is offline  
post #8 of 21 (permalink) Old 2-24-17, 18:02

 
Join Date: Sep 2011
Location: Salisbury
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Power: 5
 
Make sure the ignition is OFF. The VAF which is normally marked as JE02, is between the air box and the throttle body. Check that the plug to the VAF is not corroded, disconnect the plug and scratch the terminals with a knife/blade to clean them and spray some penetrating fluid into both ends. If the problem persists .. let me know.

17" ROH Adrenaline Alloy Wheels, Superchip (for hi-octane +12hp), Stainless steel scuff plates, Powerfolding jdm mirrors, Mazda 6 MPS brakes (front + rear), 929 brake master (mx6 reservoir), JDM headlights, Altezza tail lights, Modified stock radio/cd with line-out +amp, Sound deadened doors + rear quarters << massive improvement
gwq_uk is offline  
post #9 of 21 (permalink) Old 2-24-17, 18:08

 
Join Date: Sep 2011
Location: Salisbury
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Power: 5
 
Make sure the ignition is OFF. The VAF which is normally marked as JE02, it is between the air box and the throttle body, it has a plug connected to it. Check that the plug to the VAF is not corroded, disconnect the plug and scratch the terminals with a knife/blade to clean them and spray some penetrating fluid into both ends. If the problem persists .. let me know.

17" ROH Adrenaline Alloy Wheels, Superchip (for hi-octane +12hp), Stainless steel scuff plates, Powerfolding jdm mirrors, Mazda 6 MPS brakes (front + rear), 929 brake master (mx6 reservoir), JDM headlights, Altezza tail lights, Modified stock radio/cd with line-out +amp, Sound deadened doors + rear quarters << massive improvement
gwq_uk is offline  
post #10 of 21 (permalink) Old 2-24-17, 18:24 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Hello everyone, So I took a video of the engine codes I am throwing. Can someone please help me diagnose these?

jakobw5 is offline  
post #11 of 21 (permalink) Old 2-24-17, 18:28 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
From what I see, got these...

08- MAF sensor/circuit
117- ECT
23- Rear 02
24- Rear 02

Can someone double check me on that? And then tell me exactly what I should be looking for or replacing.
jakobw5 is offline  
post #12 of 21 (permalink) Old 2-24-17, 18:37 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Pulled the plug on the VAF, no corrosion of any kind, everything looks clean.


jakobw5 is offline  
post #13 of 21 (permalink) Old 2-24-17, 18:38 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
jakobw5 is offline  
post #14 of 21 (permalink) Old 2-24-17, 18:40 Thread Starter
New Member
 
Join Date: Feb 2017
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
jakobw5 is offline  
post #15 of 21 (permalink) Old 2-24-17, 18:53

 
Join Date: Sep 2011
Location: Salisbury
Posts: 66
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Power: 5
 
Take a look at this video..
it is not for an MX6 but the process is just the same.

17" ROH Adrenaline Alloy Wheels, Superchip (for hi-octane +12hp), Stainless steel scuff plates, Powerfolding jdm mirrors, Mazda 6 MPS brakes (front + rear), 929 brake master (mx6 reservoir), JDM headlights, Altezza tail lights, Modified stock radio/cd with line-out +amp, Sound deadened doors + rear quarters << massive improvement
gwq_uk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome