Car won't start... battery keeps dying! - Mazda MX6 Forums: MX6 Forum
Mazda MX6 Forums: MX6 Forum User Control Panel
 


» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Mazda MX6 Forums: MX6 Forum > Open Forums > General Automotive
Register Home Forum Active Topics Garage Garage Photo Gallery Arcade Mark Forums Read Auto EscrowAuto Loans

Mx6.com is the premier Mazda MX6 Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 7-19-09, 20:34   #1 (permalink)
  Total: 151 Power: 5
 
Join Date: Apr 2006
Location: Edmonton, AB, Canada
Age: 26
iTrader: (0)
Unhappy Car won't start... battery keeps dying!

For the past few months, I have had to get boosts or push the car a lot and pop the clutch due to the battery not having enough charge to start the car.

I turn the key, and it rolls over, and rolls over, and rolls over... very slowly though.
If I boost it with cables it starts right up.
If the car sits for usualy a few hours, and I come back out to start it, it wont start.
Sometimes (but not as usual) it wont even start after 10 minutes of being turned off.

It's driving me insane having to get boosts everywhere I go!!
HELP!!!

~Shawn.

ME: Oh no you didn't...
DRUNK PearsonMX6: I ddid too's...

http://www.cardomain.com/ride/2676149
xtreme17 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 7-19-09, 21:52   #2 (permalink)

  Total: 1142 Power: 5
 
I4MX6's Avatar
 
Join Date: Jan 2005
Location: Barrie, Canada
iTrader: (1)
You need a new battery, that's all. Go buy one. Problem solved.

-Matt-
SOLD - 1994 Mazda MX6 LS, Infiniti G35 HID conversion, 2.5" Magnaflow cat-back, 3" CAI, 16x8" FD RX7 wheels, LEDA Custom True Coilovers, shaved body and full repaint, Genuine Mazdaspeed Kit, '03 Protege rear caliper conversion, and much, much more...
I4MX6 is offline   Reply With Quote
Old 7-20-09, 1:31   #3 (permalink)
  Total: 128 Power: 5
 
anthrax1202's Avatar
 
Join Date: Jul 2007
Location: Mason City, IA, USA
Age: 25
iTrader: (3)
He's right, your battery is definently [shizzle]...I suggest a Red top Optima battery..you'll love the cold crank amps in the winter
anthrax1202 is offline   Reply With Quote
Old 7-20-09, 7:59   #4 (permalink)
  Total: 1736 Power: 5
 
Fastest95PGT's Avatar
 
Join Date: Nov 2001
Location: In ur house killing ur d00ds, MaPOC
Age: 34
iTrader: (8)
Could also just be dirty battery terminal ends which aren't allowing the battery to charge... but after this long with it being dead, might as well buy a new one anyway.

Jeff ~ 1995 PGT ZE-T MSnS-E v3 (317whp @ 8.5psi / 275whp @ 5.5psi)
PARTING A LOT OF 2g and 1g STUFF
FS: Borla for sale.
FS: Clear headlight covers, headlight, fog, tail, gauge cluster
90 PGT MTX with 97k original miles!
Fastest95PGT is offline   Reply With Quote
Old 7-22-09, 11:36   #5 (permalink)
  Total: 434 Power: 5
 
PaulG's Avatar
 
Join Date: May 2004
Location: Ottawa, Canada
Age: 38
iTrader: (6)
Also check to see how much draw you have from the battery with the engine off. Here's a great site: Diagnosing A Car Battery That Runs Down

1997 MX-6 LS
PaulG is offline   Reply With Quote
Old 7-22-09, 12:53   #6 (permalink)
  Total: 15 Power: 5
 
Join Date: Jan 2009
Location: , PA, USA
Age: 24
iTrader: (0)
after that many jumps even if it's just corrosion you'd want a new battery. I personally went with the duralast gold from autozone. it's helped me jump other vehicles, including massive pick-ups that no one else can jump. course, you might also want to check that alternator but I agree with everyone that it's battery
bavarianeagle is offline   Reply With Quote
Old 7-24-09, 22:19   #7 (permalink)
  Total: 151 Power: 5
 
Join Date: Apr 2006
Location: Edmonton, AB, Canada
Age: 26
iTrader: (0)
Replaced battery.
All is well now. :-)
Also got an Optima Red Top for FREE last night as well. So I'll have that as a spare I guess...

ME: Oh no you didn't...
DRUNK PearsonMX6: I ddid too's...

http://www.cardomain.com/ride/2676149
xtreme17 is offline   Reply With Quote
Old 9-17-09, 17:08   #8 (permalink)
  Total: 21 Power: 5
 
Join Date: May 2004
Location: Dallas, USA
iTrader: (0)
The alternator could be intermittently failing sometimes it will charge sometimes it wont I noticed this when my headlights got brighter than usual.
seansjspecmx6 is offline   Reply With Quote
Old 10-8-09, 6:26   #9 (permalink)
  Total: 11 Power: 5
 
Join Date: Aug 2005
Location: stockton, USA
iTrader: (0)
are u running any audo wires to ur battery...my amp was draining my battery until i made a kill switch to shut it off...the shop who installed my amp/sub made my system stay on with the car off which drained my battery

97 eclipse gst / injen intake / 14b turbo / greddy 18r fmic / 1g bov /apexi downpipe / rsr 3" catback exhaust / nxs mbc / 14psi / evo9 fuel pump / poly motor mounts / ACT street clutch w/ lightweight flywheel /
rathana_v is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Permissions
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 16:16.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Copyright 2000-2010, MX6.com
MX6.com is in no way affiliated to Mazda Motor Corp.
All views expressed in this site are the personal opinion of the author and not necessarily the owners of MX6.com.