Where is Shift Linkage? - Mazda MX-6 Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 6-19-07, 23:24 Thread Starter
New Member
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Where is Shift Linkage?

Hello:

I have a 1999 Mazda 626 LX 160Kmile, Automatic Transmission. I suspect it has a broken Shift Linkage. Could someone help me locate the Shift Linkage for 1999 Mazda 626? A diagram/picture with discription will be greatly appreciated.

The problem occurred couple of days ago. The engine started fine, heard one slight "click" sound when I shifted from park to drive, the car is not moving!!! I can switch into any gear easily (perhaps too easy as hand feels usually), but the car is not moving in any direction. It feels like the car is locked in park no matter what gear is shifting into. I check the tans fluid level/color/odor is fine. Do you have any suggestion about the possible reason for the breakdown?

Thanks in advance !
jb626 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 6-20-07, 3:59
 
Einstein's Avatar
 
Join Date: May 2002
Location: Barnsley, South Yorkshire
Age: 53
Posts: 10,821
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
        
Hi JB and welcome to the club..

I see you found your way to my other club as well... I can answer on both, just in case it helps others with a similar problem..

do the selector lights work as you move the lever?
does the car feel like it jerks as if trying to select a gear?


John

"Lexarse" GS 300

Still got zoom zoom zoom!
"A bus station is where a bus stops; a train station is where a train stops; on my desk I have a work station."
Cardomain page UK626Club UK & Ireland Member of the Year 2004, 2006 and 2007
Einstein is offline  
post #3 of 6 (permalink) Old 6-20-07, 22:55
 
Join Date: May 2006
Location: Round Lake
Posts: 155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
Sounds like you tranny cable popped off the shift lever, but i'm not sure.

Here is a write-up from 626.net, maybe it will help......:

Transmission Cable Quick Fix - Mazda 626 Forums

Adam
Mafia is offline  
post #4 of 6 (permalink) Old 6-23-07, 11:57 Thread Starter
New Member
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Quote:
Originally Posted by Einstein View Post
Hi JB and welcome to the club..

I see you found your way to my other club as well... I can answer on both, just in case it helps others with a similar problem..

do the selector lights work as you move the lever?
does the car feel like it jerks as if trying to select a gear?


John
John:
Thanks a lot for your help.
For some reason 99 Mazda 626 does not have gear selector lights on the dashboard as my other auto cars do. The car no movement at all (not even a shake or tremble) when I shift the gear.
JB
jb626 is offline  
post #5 of 6 (permalink) Old 6-23-07, 12:08 Thread Starter
New Member
 
Join Date: Jun 2007
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 0
 
Unhappy

Quote:
Originally Posted by Mafia View Post
Sounds like you tranny cable popped off the shift lever, but i'm not sure.

Here is a write-up from 626.net, maybe it will help......:

Transmission Cable Quick Fix - Mazda 626 Forums

Adam
Adam:

Thanks a lot for the info. Yes, I had been suspecting the plastic bushing at the end of shift rod was the culprit. But so far no luck to locate shift linkage on 1999 Mazda 626...

JB
jb626 is offline  
post #6 of 6 (permalink) Old 6-24-07, 8:40
 
Einstein's Avatar
 
Join Date: May 2002
Location: Barnsley, South Yorkshire
Age: 53
Posts: 10,821
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
        
I know US models are different, but the 3 pics I have posted below may help..








John

"Lexarse" GS 300

Still got zoom zoom zoom!
"A bus station is where a bus stops; a train station is where a train stops; on my desk I have a work station."
Cardomain page UK626Club UK & Ireland Member of the Year 2004, 2006 and 2007
Einstein is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda MX-6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome