VRIS issues - Mazda MX-6 Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 9-22-19, 16:04 Thread Starter
 
Join Date: Jul 2008
Age: 33
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
VRIS issues

Also asked this on Facebook.

I use a KL05 ecu and KL02 vaf.

Near Throttlebody VRIS doesn’t open
Distribution side opens immediatly

When I switch the wiring plugs, the vris works the other way around. (so solenoid is ok)
When using a different ecu, tested KL36 ecu and K803 ecu, both vris are opening (obviously on wrong RPMs).
Even bought 2nd ecu, kl05, same problem as my first ecu.

I also switched another KL02 vaf, still the same problem.


Who can help me figure out where the problem is of the 2nd vris not working?
Robertmx3 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 9-28-19, 3:56 Thread Starter
 
Join Date: Jul 2008
Age: 33
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
Nobody can give me some pointers?
Robertmx3 is offline  
post #3 of 6 (permalink) Old 9-28-19, 9:00
 
Join Date: Feb 2019
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 1
 
You mention both VRIS operate when you switch the wiring.
You mention both VRIS work when you have put in different ecu's.
It sounds like not much else to diagnose.
Goodbar is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 10-1-19, 4:14 Thread Starter
 
Join Date: Jul 2008
Age: 33
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 5
 
Got another KL05 ECU and still the same problem.

Perhaps I don't understand well enough how the VRIS is supposed to work.

This is what I got from the manual, but I am in doubt now. Could somebody verify this?
VRIS #1
reduction 3250rpm wide open throttle
66%< WOT
does it mean this VRIS is closed when under less load?

VRIS #2
reduction 4250 rpm
Robertmx3 is offline  
post #5 of 6 (permalink) Old 10-2-19, 7:34
 
Join Date: Feb 2019
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Power: 1
 
At idle, Vris #1 is open.
Both closed to 3250.
Vris #1 opens. 3250 to 4250
Vris #2 opens 4250.
Both open 4250 to 6250
After 6250 both closed
Goodbar is offline  
post #6 of 6 (permalink) Old 10-11-19, 15:50
 
Join Date: Feb 2004
Location: Chelsea Quebec
Posts: 2,662
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Power: 5
       
If I remember correctly, the VRIS solenoids only open at or near Wide Open Throttle.

Try this: start the engine, to build up vacuum, then stop the engine. Connect ten and gnd pins in the Diagnosis box (to put the car in diagnostic mode, as if reading the codes). Then watch the VRIS solenoids when a friend turns the ignition key to "on". The ecu does a self-test, and both VRIS solenoids should open momentarily, then close.
NickR is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome