Mazda MX-6 Forum - Reply to Topic
Thread: New Member Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Mazda MX-6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-31-18 20:20
Todd Volpe So I checked with my mechanic about the KL-ZE swap and he is concerned about electronic compatibility with the computer. Will there be engine lights having to do with fuel mixtures being wrong, emission issues and what have you. He implied that tackling these kinds of problems would increase labor costs. He told me that he would take a week to research the swap and get back to me. He said I should ask the group here as well.
10-26-18 0:03
jchunter Don't be so quick to get rid of it. I had the engine replaced in my 1995 MX6 (at 210,000 miles) with a low-mileage KL-ZE for $2,100 by Nova Speed Shop in Manassas back in 2017. It's now at 255,000 and I haven't regretted my decision for a second.
10-17-18 19:43
Todd Volpe
New Member

Todd Volpe
‘95 MX-6 LS
[email protected]
Bucks County SE Pa
My wife had this car fall in her lap, little old lady single owner with 49k miles on when she bought it. We replaced the distributor, plugs, wires, battery, alternator and crankshaft sensor. There was oil from a leaky valve cover gasket that was scheduled to be replaced. It has a rough idle that initially was thought would go away after the valve cover gasket and necessary intake manifold removal and replacement. When my mechanic got the car to do the work after about a month he noticed that it seemed to be idling a little rougher than it should and did a compression test and found #3 to be low. He expects it to be a burned valve because the cam isn’t noisy. He advised me not to put another cent into it and move on to another car.
This car otherwise is in good shape with 60k miles. If anybody has any interest in purchasing please feel free to contact me.

Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome