Mazda MX-6 Forum - Reply to Topic
Thread: Fuel cut after installing chip Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Mazda MX-6 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
7-21-19 9:31
Mazda_Powered Car can spike to 12psi , beeps, cuts, teeth smash, the whole bit lol. Currently only running a 2.25" turbo back exhaust.

Bought a Probe LX on Tuesday, so the 626 will just stay parked for a while...probably save up for microsquirt.

Quote:
Originally Posted by 3.0smokedrice View Post
This post is a little odd to me. Are you running a boost controller?

If you set the boost to say.. 10.. can you fully drive the vehicle then? No issues with full throttle?

My car drove fine as long as I kept it below the 12 psi. If I raised the boost then when I hit high psi it would cut out.

Now your issue may be chip related, as I don't know what else that particular chip does. Does the car beep at you when it cuts out?

Based on your post im feeling like you do have a large boost leak.


Quote:
Originally Posted by Mazda_Powered View Post
I got my chip from goodchildren. Purchased from ebay, but was dealing with him over the forum here. Nothing was resolved, didn't feel like asking for my money back either. idk. Car is parked now anyways lol couldn't go more than 2/3 throttle without it cutting on me. Kinda made the car unpredictable to drive. Life I guess
7-18-19 17:58
juanpac_tupac Glad you had success with the new chip!
7-18-19 14:10
DarkMx-6
Quote:
Originally Posted by 3.0smokedrice View Post
Yea. I'm going to have to do some serious reading, before I make the change. It's hard when I have a currently great running 89 to hack into it.

Probably be a winter time project and closer to fe3 swap time.
don't make the mistake of doing megasquirt and FE3 at the same time.

Megasquirt your already running F2T then maybe think of doing the FE3. I'm telling you this from experience. I wasn't doing an FE3 but it was a swap into another car. (see sig) My project is about to hit it's 10 year anniversary, still not done. Slight progress is being done now. I wish I would have learned MS first then did the swap. You live and you learn. I'm now I totally abandoned MS for Haltech. I am Not saying that MS is bad or that it is not as good it's just too many ingredients for an already complicated soup.
7-17-19 23:53
3.0smokedrice This post is a little odd to me. Are you running a boost controller?

If you set the boost to say.. 10.. can you fully drive the vehicle then? No issues with full throttle?

My car drove fine as long as I kept it below the 12 psi. If I raised the boost then when I hit high psi it would cut out.

Now your issue may be chip related, as I don't know what else that particular chip does. Does the car beep at you when it cuts out?

Based on your post im feeling like you do have a large boost leak.


Quote:
Originally Posted by Mazda_Powered View Post
I got my chip from goodchildren. Purchased from ebay, but was dealing with him over the forum here. Nothing was resolved, didn't feel like asking for my money back either. idk. Car is parked now anyways lol couldn't go more than 2/3 throttle without it cutting on me. Kinda made the car unpredictable to drive. Life I guess
7-17-19 23:41
3.0smokedrice Received the new chip today. I installed it and seems as though boost cut is finally gone. It is wet outside so I spin the wheels once the boost gets up there, but it seemed to be holding 16 without any issue in higher gears.

So I gotta give goodchildren the thumbs up after all.

I will say, I don't know if you bought the ECU already chipped or if you installed it. I bought mine already ready to go. When I opened it up to switch the chips, it looked as though the Probenator was not seated all the way.

Worth looking at.


Eric

Quote:
Originally Posted by Mazda_Powered View Post
Please could you post your results? I'm really trying to avoid going with an aftermarket ecu lol.
7-16-19 15:31
3.0smokedrice Yea. I'm going to have to do some serious reading, before I make the change. It's hard when I have a currently great running 89 to hack into it.

I for sure see the benefits though. Probably be a winter time project and closer to fe3 swap time.

For now I'll try to just get a good chip to eliminate fuel cut, and then work on adding more fuel/supporting mods for bigger turbo.
7-15-19 22:32
juanpac_tupac Diyautotune has excellent reading material for installing the MS systems. Id do lots of reading before taking a stab at it. It really wasnt that hard to install for me, proper connectors and tools really makes a difference. Went through a lot of head scratches because i saved a few bucks not buying the proper tools for the job. Lesson learned. There is auto tuning software available for MS systems as well. Pretty good stuff to help you after youve already went through and set it up with your info. A professional would be recommended for the tuning side or just take your time and learn the processes. Good street tune and my auto tune function and ive yet to go on a dyno. Granted only at 8 psi for now with my set up. There are easier ways and there are harder ways to go about it. I like having full control over my engine and invested in the ms3x system. Just about the best supporting mod you can buy if you plan on making changes to your cars performance. Not sure how chipping really works as i am from a different generation and didnt get to mod cars in the earlier 2000s and stuff. I know some folks still use them which i think is awesome. I like being able to tell my computer the size and specs of my new injectors in 15 seconds or less. Or what my new coil pack specs out at as i plan on upgrading to a full sequential ign set up instead of wasted spark, which im using currently. Test all injectors from the computer, bang your coils. Set up your water meth on it. Fuel pump on off controls. So many things thatd save time when troubleshooting or adding new components. Plus the added benefits of progressive boost control and fine tuning your launch control set up. All sorts of goodies. Love my Megasquirt 3 X ems, still have most of my inputs and outputs to be used in the future so its good investment for all my plans. Also, my tablet uses the app thats associated with efi analytics to display my gauges and tach via Bluetooth, and theres a Heads up display mode that mirrors the graphics. Velcro straps holding it on my dash. See through reflective tape on a small section of windshield above my dash. Full heads up display of all my stuff. Wonderful
7-15-19 18:10
DarkMx-6 I'm not trying to get you down but MS is not for the faint of heart and there is a lot of money involved even after you install everything and have it idling on MS. For example: Tuning

You'll have to do a lot of research about it. There is tons out there on this site and more on others.

assembled

https://www.diyautotune.com/shop/megasquirt-assembled/

MS kit

https://www.diyautotune.com/product/...-w-black-case/

There is a lot to know so you'll have to really be into reading and looking up stuff.
7-14-19 17:30
3.0smokedrice Excuse my ignorance.

Difference from assembled and disassembled?

Which year are they for? I have 89.

The assembled version does that mean complete and comes with everything I need?

I've been looking info fmu and fpr, but I know inside Ms is the way to go. Especially since fe3 is in my future.

Thanks.




Quote:
Originally Posted by DarkMx-6 View Post
Yes Rob = Probinator

I have two megasquirt ECUs One unassembled
7-14-19 9:50
DarkMx-6 Yes Rob = Probinator

I have two megasquirt ECUs One unassembled
7-13-19 15:41
Mazda_Powered Please could you post your results? I'm really trying to avoid going with an aftermarket ecu lol.
7-12-19 15:19
3.0smokedrice Yea that's who I got mine from.

He is sending me a new zombie and a new Probenator. Maybe it's just his Probenator software. Lame though.

Hopefully I don't have to buy from someone else, but I will. So of anyone wants to sell let me know
7-12-19 14:02
Mazda_Powered I got my chip from goodchildren. Purchased from ebay, but was dealing with him over the forum here. Nothing was resolved, didn't feel like asking for my money back either. idk. Car is parked now anyways lol couldn't go more than 2/3 throttle without it cutting on me. Kinda made the car unpredictable to drive. Life I guess
7-12-19 13:59
Mazda_Powered Ditto here. Fuel cut from a probinator chip. Seller advised the chip is either backwards or there is a boost leak. Neither showed to be an issue. I turned the boost down to fix it....because idk what else to do. Lol
7-12-19 11:31
3.0smokedrice Re read. I believe you mean you have two chips available? One in an ECU and one not?

As for Rob, he is probenator? And can help with a new chip also?

Thanks.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Permissions  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome