Mazda MX-6 Forum - Search Results
Advanced Search
Showing results 1 to 25 of 750
Search took 0.13 seconds.
Search: Posts Made By: NickR
Forum: 2G MX6 General   Today, 14:41
Replies: 6
Views: 1,387
Posted By NickR
The same thing happened to me once. The new (i.e....

The same thing happened to me once. The new (i.e. remanufactured) alternator was bad. It seems this happens a lot.

But first double-check all the connections are clean and tight.
Forum: 2G MX6 General   Today, 14:36
Replies: 2
Views: 16
Posted By NickR
Try an internet search to see if they have the...

Try an internet search to see if they have the same part number.

I'm getting mixed results for part number GA2A76220F (some sites said "right", but a German site said "L", which I think stands for...
Forum: 2G MX6 General   Yesterday, 20:15
Replies: 18
Views: 644
Posted By NickR
Jonathon: this is the 2G (second generation,...

Jonathon: this is the 2G (second generation, 1993-1997) section of the forums. You should try posting in the 1G (1988-1992) section.

Did you try an Ebay search?
Forum: 2G MX6 General   12-4-19, 20:17
Replies: 3
Views: 69
Posted By NickR
Dunno. Maybe the window rollers are similar to...

Dunno. Maybe the window rollers are similar to some other Mazda (or Ford)? Might be worth going to a pick & pull junkyard and seeing what you can find.
Forum: 2G MX6 General   11-18-19, 11:56
Replies: 6
Views: 1,234
Posted By NickR
From the symptoms you describe, my guess is that...

From the symptoms you describe, my guess is that you have a small leak from the front or rear valve cover gasket, so oil is dripping down onto the hot exhaust manifold, hence the smell. Replacing the...
Forum: 2G MX6 General   11-5-19, 16:57
Replies: 9
Views: 191
Posted By NickR
"Plastic rubbing sound"? I would remove a few of...

"Plastic rubbing sound"? I would remove a few of those 10mm bolts that hold the timing belt cover on, and have a peek inside. See if the timing belt is badly worn, or split, or loose, or something,...
Forum: 2G MX6 General   10-29-19, 8:40
Replies: 2
Views: 126
Posted By NickR
It could be the coil, or could be the ignitor...

It could be the coil, or could be the ignitor (also a common problem, perhaps more common than the coil).

You might get lucky, and someone who knows will answer your question. But probably not,...
Forum: 2G MX6 General   10-22-19, 20:19
Replies: 6
Views: 206
Posted By NickR
Just for a laugh, remove the oil dipstick when...

Just for a laugh, remove the oil dipstick when the engine is idling normally. It should create enough of a vacuum leak to stall the engine.
Forum: 2G MX6 General   10-22-19, 19:58
Replies: 6
Views: 206
Posted By NickR
That's good to hear! Just to be sure: you...

That's good to hear!

Just to be sure: you adjust the idle with the big Phillips (X) screw that is embedded in the top of the throttle body. Don't touch the tiny little screw that is near to where...
Forum: 2G MX6 General   10-21-19, 19:08
Replies: 6
Views: 206
Posted By NickR
Welcome to the board! My guess is that one...

Welcome to the board!

My guess is that one of the vacuum lines got disconnected, or a vacuum leak between the VAF meter and the throttle body, when the distributor and crank position sensor were...
Forum: 2G MX6 General   10-16-19, 8:27
Replies: 9
Views: 191
Posted By NickR
I use any full synthetic 10W30 in summer and 5W30...

I use any full synthetic 10W30 in summer and 5W30 in (Canadian) winter. I think these are the recommended weights. Some people are fans of particular brands, but I don't think it matters much.

A...
Forum: 2G MX6 General   10-11-19, 16:57
Replies: 9
Views: 191
Posted By NickR
I think this is probably a dirty/sticking...

I think this is probably a dirty/sticking Hydraulic Lash Adjuster (just like a collapsed lifter). Try changing the oil, and making sure the oil level is topped up full.
Read this for more info:...
Forum: 2G MX6 General   10-11-19, 16:50
Replies: 5
Views: 215
Posted By NickR
If I remember correctly, the VRIS solenoids only...

If I remember correctly, the VRIS solenoids only open at or near Wide Open Throttle.

Try this: start the engine, to build up vacuum, then stop the engine. Connect ten and gnd pins in the Diagnosis...
Forum: 2G MX6 General   9-11-19, 14:30
Replies: 3
Views: 302
Posted By NickR
If a bad ECU/PCM was causing the O2 sensor codes,...

If a bad ECU/PCM was causing the O2 sensor codes, I think it would cause the O2 codes for both banks, not just one bank of cylinders. Are you sure the front bank cylinders are getting a good spark...
Forum: 2G MX6 General   9-11-19, 13:45
Replies: 3
Views: 207
Posted By NickR
Wikipedia says there's a 140hp KFDE, as well as...

Wikipedia says there's a 140hp KFDE, as well as the 160 (or 170) hp KFZE.
I think the main difference is a higher compression ratio for the ZE (so it needs premium gas).

The K engines were sold...
Forum: 2G MX6 General   9-1-19, 21:43
Replies: 8
Views: 273
Posted By NickR
1. I don't think the year matters. The 93 MX6...

1. I don't think the year matters. The 93 MX6 (dunno about the MX3) had an extra coolant temp sensor that controlled the fans, (but you can always swap the neck from near the coolant filler cap if...
Forum: 2G MX6 General   7-14-19, 21:19
Replies: 28
Views: 567
Posted By NickR
"2. Disconnect the sensor harness at the TPS and...

"2. Disconnect the sensor harness at the TPS and check the P wire for +5V with the ignition on......

3. Measure the voltage at the Y wire while slowly opening the throttle by hand (engine off). It...
Forum: 2G MX6 General   7-3-19, 16:51
Replies: 28
Views: 567
Posted By NickR
Yes. The small, single wire sensor controls the...

Yes. The small, single wire sensor controls the gauge.
Forum: 2G MX6 General   7-3-19, 15:33
Replies: 1
Views: 141
Posted By NickR
I thought you had to remove the gas tank to...

I thought you had to remove the gas tank to replace the fuel pump (at least on the V6, and I think the I4 would be the same).

Here is a video for the 626, which is mechanically identical:...
Forum: 2G MX6 General   7-3-19, 15:25
Replies: 28
Views: 567
Posted By NickR
I don't remember reading of many/any failed oil...

I don't remember reading of many/any failed oil pumps on this board. And I don't think it would cause those symptoms anyway.

How hot is the weather where you are? In very hot weather, and in...
Forum: 2G MX6 General   6-30-19, 21:20
Replies: 28
Views: 567
Posted By NickR
A bad ecm seems unlikely to me. Don't remember...

A bad ecm seems unlikely to me. Don't remember many cases.

By the way, when you remove the spark plugs, do any of them show signs of running rich (black sooty deposits instead of whitish)?
Forum: 2G MX6 General   6-28-19, 12:01
Replies: 7
Views: 430
Posted By NickR
OK, that doesn't sound like a slipping clutch,...

OK, that doesn't sound like a slipping clutch, and it may be the CV joints after all. You could try grabbing the axles by hand, and see if they move when you pull or push them. Or put the car in high...
Forum: 2G MX6 General   6-25-19, 18:06
Replies: 28
Views: 567
Posted By NickR
A search on "fuel pressure regulator" doesn't...

A search on "fuel pressure regulator" doesn't bring up much, so it's not a common problem. (And I don't know the answers to your specific questions.) But this thread might be interesting: see...
Forum: 2G MX6 General   6-24-19, 20:36
Replies: 2
Views: 128
Posted By NickR
Well, the wheel would be out of balance, but...

Well, the wheel would be out of balance, but since the lug nuts are so near the wheel center, it wouldn't affect the balance as much as missing a similar weight on the circumference of the wheel.
...
Forum: 2G MX6 General   6-24-19, 20:30
Replies: 28
Views: 567
Posted By NickR
I remember reading on one of the forums that some...

I remember reading on one of the forums that some parts stores have the wrong part number listed for the front sensor (the one that controls the fans, and gives code 69). But the only problem if you...
Showing results 1 to 25 of 750

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome