Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
744 Posts
Discussion Starter #1
OK here's the scoop, I just swapped out my T3 for a new hybrid T04E turbo and I now have it installed but it NO WORKY! I have the turbo functional and bolted up. At first there were some bad exhaust leaks on that square inlet flange and it had A LOT of lag time and I barely got 4 psi thru all of 2nd gear. I was actually smart and went easy on the turbo for a long time and broke it in properly with lots of time just idling and on the freeway w/ the cc on.

OK so the last time the car was boosting with lots of lag the bov actually blew off while I was still accelerating so I figured I blew out a coupler or hose somewhere but everything checked out fine. I fixed most of the exhaust leaks yet the inlet is still BARELY leaking. But I should still get some boost instead of 2 psi of vaccum at WOT. I have an internal wastegate and here's the pic of the wg housing to probe that it was sealing off the little hole on the exhaust housing:

So the wg is sealed just fine now, the turbo is brand new so the seals are all ok, the actuator checked out fine, and there were no apparent boost leaks on piping. Soooo does anyone have any ideas cause I have spent days shaking my head and and I am lost! One thing I noticed is that the BOV sucks in alot of air at idle and I dont know if its just not working and letting the building boost just leak out. BEATS ME! someone help cause I am tired and lost :(
 

·
Registered
Joined
·
2,229 Posts
Hey Dan,

I talked to my manager at work (he's a big boosthead) He said chances are, your Leaky BOV Is 90-100% of all your probs. He said even a little leak will make a huge dif. in boost. So fix the prob, cuz i wanna see this thing in action on the 18th. I also have my own little porbs and questions to bring up to you then.



Adam
 

·
Registered
Joined
·
744 Posts
Discussion Starter #3
I dunno bout the 18th, its looking like the car will be MIA :( My turbo is defective and is getting sent back. The exhaust blades were dragging on the housing to the extent that it makes noise and it wont let the turbine spin freely enough to spool.


SOOO I am trying to find a new turbo like NOW to get it done for the meet but its looking bad. I cant find any decent affordable turbos at the moment :mad:
 

·
Premium Member
Joined
·
10,652 Posts
DrBrown said:
I dunno bout the 18th, its looking like the car will be MIA :( My turbo is defective and is getting sent back. The exhaust blades were dragging on the housing to the extent that it makes noise and it wont let the turbine spin freely enough to spool.


SOOO I am trying to find a new turbo like NOW to get it done for the meet but its looking bad. I cant find any decent affordable turbos at the moment :mad:
whats your name on PT cuz i've read the same_exact problem on there :) even down to the faulty turbo.
 

·
Registered
Joined
·
2,229 Posts
His name on PT Is groghscv. Just thought i'd help.



Adam
 

·
Premium Member
Joined
·
10,652 Posts
Mx6kRaZy_03 said:
His name on PT Is groghscv. Just thought i'd help.



Adam
ok :) thats who i was talking about on PT then too lol
 

·
Registered
Joined
·
744 Posts
Discussion Starter #7
HA everyone talkin behind me's back eh?? Well yes its a faulty ass turbo alright and is getting shipped back for a refund tomorrow. I am just gonna use a T-brid turbo for the time being. Its prolly gonna be worth 230-240 whp max running at 8 psi. I dont really need a hybrid, its a trade off. You can run more boost on a little turbo and its equal to a larger one if the fue lis there. No biggy, I never meant to go out and break any power records cause my engine is half way to a rebuild by now. I just wanted to beat those damn LT1's and WS6's on the streets. So I should be REAL close to that goal with the upgraded t-bird & intercooler. Here's the pic of it from ebay where I found it and had him overnight it to me :)


BTW, is it a good sign when your turbo screeches and grinds at 3,500 rpm's??? Didnt think so hehe, be weary of buying the turbos on ebay that say TURBO ZY on the compressor for a while till the bad batch disappears.
 

·
Premium Member
Joined
·
10,652 Posts
DrBrown said:
HA everyone talkin behind me's back eh?? Well yes its a faulty ass turbo alright and is getting shipped back for a refund tomorrow. I am just gonna use a T-brid turbo for the time being. Its prolly gonna be worth 230-240 whp max running at 8 psi. I dont really need a hybrid, its a trade off. You can run more boost on a little turbo and its equal to a larger one if the fue lis there. No biggy, I never meant to go out and break any power records cause my engine is half way to a rebuild by now. I just wanted to beat those damn LT1's and WS6's on the streets. So I should be REAL close to that goal with the upgraded t-bird & intercooler. Here's the pic of it from ebay where I found it and had him overnight it to me :)


BTW, is it a good sign when your turbo screeches and grinds at 3,500 rpm's??? Didnt think so hehe, be weary of buying the turbos on ebay that say TURBO ZY on the compressor for a while till the bad batch disappears.
nah just that i noticed your thread on PT as wel.. u also gave me a TON of advice a while back (thanks again! :))
 
1 - 8 of 8 Posts
Top