Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
my girlfriend has a 1988 Mazda 626, just tuned up and has a new battery, yesterday went to start it and acted dead, light went dim then totally out, the battery is full charged and cant find any blown fuses, anyone have a Idea what might be wrong with it??
 

·
Registered
Joined
·
694 Posts
OK, just went thru this with my son's 91 626. Check all your connection!! Especially your grounds-follow them, un-bolt and clean, or lightly sandpaper them, and hook back up. Clean both the pos. and neg. terminals really good with a terminal cleaner that has the wire on the inside and outside for both clamps and posts. I wnet over my son's for 2 hours, only to find corrosion inside the neg. clamp!!:mad: Also, check the pos. lead at the starter.:shrug:
 

·
Registered
Joined
·
3,068 Posts
- is the starter turning the engine over?
After checking the connections (loose ground to the starter motor/engine block will getcha!)

- check for spark
- check for fuel (can you hear the fuel pump, below the passenger seat in rear? )
 

·
Registered
Joined
·
10 Posts
did you manage to fix the fault?
if not, i would suggest getting the new battery checked.
A faulty battery can show 12v with a multi meter but just not have the power to start the car. of course an old battery just wont hold a charge and will show less that 12v :)

otherwise just as Mrmoose said, double check all the ground connections.
 
1 - 6 of 6 Posts
Top