Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Driving down road the engine just quit for no reason,it felt like it was out of gas.After turning it over a few times,I got out and loosened gas cap, got back in and it started right up,20 mins later it did it again and I loosened cap and it started back up again, it is running good but the noise in the rear head seems louder and I just found out old owners put 20w50 oil in her ,I haven't changed oil in it since I 've owned it bcuz I havent driven it 1000 miles yet.I dont know these v6 motors and can use alot of help! So can someone help this confused 60+ yr old out,I'm stumped. It's a 93 MX6 w/2.5 l. auto. Thanks
 

·
Registered
Joined
·
2,711 Posts
When the engine quit, did you notice if the rpm on the tachometer immediately dropped to zero, even while the car was still rolling and the engine still turning? If so, that's the classic symptom of ignitor/distributor failure (a common problem with our V6 cars). Plus it starts up again in a few minutes, when the distributor cools down a bit. (If this theory is right, your loosening the gas cap was just a coincidence.)
 

·
Registered
Joined
·
2 Posts
I would say distributor too, when mine died it wouldn't start again so that is a little different than your issue.
 

·
Registered
Joined
·
133 Posts
It sounds like a title suitable for a James Bond car.....Die another day.....You only live twice.
But if the car stops, that won't be good.
Sounds more like a fuel pump issue if you keep releasing the gas tank pressure, and the car starts again.
 
1 - 4 of 4 Posts
Top