Mazda MX-6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
533 Posts
Discussion Starter · #1 ·
Ok here's the list of parts i've replaced that improved the cars power and what not.

-cap/rotor/plugs/wires
-vaf (old one was messed up badly)
-installed a Spectre high flow airfilter

The problem i'm having is after the car warms up. Not even at normal operation temps.

Car cold: drives nice shifts quickly and pulls like a 2.5 v6 should

Car normal operating temps: shifts slip a bit (nothing out of the norm), but the car really seems to lag in gerenal, maybe 10% slower. Car also lags with a WOT (wide open throttle) shift from 1st -> 2nd gear.

Any ideas what causes the lag and shift bog when warm? The car is not having any ignition issues, everything has been tested. No check engine light.

Also there's a light sulfur smell the odd time from the exhaust pipe.

JACK.
 

·
Premium Member
Joined
·
5,189 Posts
The smell suggests that the cat may be clogged. The shift lag may be due to that, so I would swap out or eliminate the cat first (for testing purposes only), and if the problem persists with the shift lag, then maybe your tranny is on its way out. In that case I would at least change the tranny fluid and filter to see if the situation improves.
 

·
Registered
Joined
·
533 Posts
Discussion Starter · #3 ·
ok i'll just do a pressure test pre and post cat, i did an engine flush and sucked up some fuel cleaner in the vac port (for cruise control) to maybe clean out carbon in the intake manifold.

There was a huge difference in drivability then, more power, and I think I was having a sticky vris issue, but now i'm not (the intake sounds deeper and a more tuned note...music to my ears!)

I do think the sulphur smell i was getting might be from the oem cat converter. I'll see what i can do about getting my magnaflow on there.

JACK.
 

·
Registered
Joined
·
533 Posts
Discussion Starter · #4 ·
AS IF YOU DROPPED THE TRANNY BOMB TOO! I just saw that! the trans has to last me at least 3-4 months til i have everything for my mtx swap!!! you better knock on wood man! haha. but ya, the fluid is getting 50/50 on the red/brown colour.

I'll swap all 8.8L out this weekend if i can disconnect the trans cooler lines easily. if not i'll just drop and drain the bellhousing fluid a couple times hah.

JACK.
 

·
Premium Member
Joined
·
5,189 Posts
Good luck man, I think it should last 3-4 months as long as you don't rip it too much.
 
1 - 5 of 5 Posts
Top