Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Is it possible to wire a single wire knock sensor to work with a 93 Mazda MX6? I changed the engine in my MX6 to one that came out of a Maxda Millenium. I have swapped over most of the required parts, however I neglected to check the knock sensor. The new engine has a single wire sensor whereas the old engine was equipped with a 2 wire sensor. I have the engine in the car and of course the old harness has a 2 prong connector while the knock sensor in the new engine is single wire.
Is there a way to wire the single wire knock sensor so it will work with the existing ECU?
 

·
Registered
Joined
·
2,689 Posts
I don't know. But if you decide to swap the sensor, you might find this useful:
 

·
Registered
Joined
·
72 Posts
Are you asking this because you don't want to change out the knock sensor from a 1 wire to a 2 wire ?
Or another reason ? I also installed a Millenia engine into my MX6, and used a 2 wire knock sensor.
This is not a difficult job to do, with a leisurely approach it can be done in an afternoon, even taking off the intake manifold.
 

·
Registered
Joined
·
2 Posts
I would definitely not risk it leaving a single wire. May I ask why you don't want to just swap to a 2 wire and roll with it?
 

·
Registered
Joined
·
72 Posts
I can't find the button for starting a new thread. It used to be right above all these question and answer type posts.
Can someone tell me where it is now, so I can start a new thread ?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
I did a lot of work to swap one engine to the other and I was discouraged by the extra work required to swap out the knock sensor, plus I had put all new gaskets and seals in the cooling system under the manifold. It turns out the knock sensor was also 2 wire. it appears that the millenia only had input from one wire, after some research I determined that there was a second wire. I cut the connector off of the knock sensor and wired it to the sensor in the new engine
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
I cut the connector off of the single wire and realised that it had the same cable as the 2 wire. I used the old 2 wire connector wired to the knock sensor and it worked.
 
1 - 8 of 8 Posts
Top