Mazda MX-6 Forum banner
1 - 3 of 3 Posts
G

·
Discussion Starter · #1 ·
Hi all,
I got a 93 MX6-LS 5sp. I got the following problems with the car lately:
-- Airbag senser is now flashing
-- Driver Power seat stop working


Is there anything that I can do to fix it beside taking to the dealer ?

Thanks very much in advance and please direct me to the right forum if I am at the wrong one.

dtammx6
 
G

·
Discussion Starter · #2 ·
I'm a 1st gen guy, so I can only give you general information. The best place to ask for specific information is "2nd Gen Maintenance".

Anyways, your airbag light is probably flashing an error code, A quick look in the FAQ's in the 2nd gen section might help there.

The driver side seat? I'd first check to see if theres a loose connection or a blown fuse, after that, I'd remove the switch unit and spray some Electronic clean and lube into it, and work the switch a few times.

If that doesn't help, you could try running 12 volts to the seat motor directly to see if it is at fault.
 

·
Registered
Joined
·
2,116 Posts
FlySwat said:
I'm a 1st gen guy, so I can only give you general information. The best place to ask for specific information is "2nd Gen Maintenance".

Anyways, your airbag light is probably flashing an error code, A quick look in the FAQ's in the 2nd gen section might help there.

The driver side seat? I'd first check to see if theres a loose connection or a blown fuse, after that, I'd remove the switch unit and spray some Electronic clean and lube into it, and work the switch a few times.

If that doesn't help, you could try running 12 volts to the seat motor directly to see if it is at fault.
thats what i'd do :tup:
 
1 - 3 of 3 Posts
Top