Mazda MX-6 Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 · (Edited)
94 Automatic, shifts hard 1st to 2nd

My daughters 94 4 cyl auto transmission shifts hard from 1st to 2nd. I have changed the fluid using mercon III as recommended and no help. Will having it flushed out help? I was told by a trans shop that it wouldn't. Are there any adjustments that could help? Should I just have the codes read and go from there?

Also, The "L" shaped lower rear motor mount needs replacing and maybe the lower front as well. Could this be part of the problem or is this a symptom of the hard shifting?

Any help is appreciated.:help:
 

·
Registered
Joined
·
146 Posts
I have the 6cyl atx and it shifts very roughly, especially when accelerating faster. This is, however, typical of our transmissions. Does it always do it? Mine typically is fairly smooth when accelerating slowly - some days worse than others. I would pay close attention to it to make sure it doesn't get worse, and all will probably be fine.

Also, even though it's "automatic" I've found that I can make it drive more smoothly through carefull use of the throttle. Unless you think it is really an actual problem (popping out of gear, not engaging, etc.) you shouldn't worry too much.

Mike
 

·
Registered
Joined
·
12 Posts
Torn mounts will give you a "hard shift" feeling. Especially from 1st to 2nd, a torquey shift. Replace your mounts :tup:
 

·
Registered
Joined
·
2,116 Posts
how do u tell if the mounts are bad? mine seem to be intact and not cracked, is there a way to tell if theyre bad?
 
1 - 6 of 6 Posts
Top