Mazda MX-6 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
I have a mazda 626 94 atx 2 liter. It has a Ford eec iv connector. Anyone know of a tool to scan for codes. Or can I just jump something to something. It is def not OBDll. CEL light comes off and on and it seems weak pulling uphill.
Thx PGP:jump:
 

·
Registered
Joined
·
1,822 Posts
i think u should be able to jumper the grn and ten pins on ur diagnostic port in the engine bay
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
There is no tens pin in the diagnostic control box. It is only half full and that half is missing . It is a mixed version Mazda DLC and Ford EEC IV connector. I only have a STI in the EEC IV box .

Thx PGP

Any other thoughts
 

·
Registered
Joined
·
18 Posts
Proper procedure can be found on www.performanceprobe.com in the 'do it yourself' section, under 'diagnosis'. You will also find the interpretations of the engine codes there. In the same 'diagnosis' section, you can learn how to pull and interpret your ATX fault codes as well. Very informative site, and I strongly recommend it.

In short though, on the 2.0 models of the mx-6, 626, and probe, instead of placing a jumper wire between the GND and TEN terminals in the diagnosis port, you place the jumper between GND and STI. Hope this helps. good luck!

Daniel
 

·
Registered
Joined
·
24 Posts
Discussion Starter #5
The STI in the Diagnostic connector box in my CAR is the C slot in the Mazda connector according to the Haynes Mazda 626 & Mx 6 Ford Probe manual. That slot is empty! I have a STI in the EEC IV but no ground in that connector so I grounded it directly to the negative battery terminal. This is a real Bastardized version of the car.The book says 2 types of connectors are used depending on engine etc . My car has both types as opposed to either one or the other.
Thx a lot for that site Maybe I can learn something from it
PGP
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
Thx Daniel

That is a great site. I found out 95% of what I need but how do I find out which O2 sensor is bad? According to Mazda the car has 3. I have heard in other rooms that this model has only one. As I am now in the USA and my wife knows nothing about cars I dont know what to believe. The codes 159 MAf and 181 heated Os sensor circuit make sense now.I am considering just buying both these parts and installing when I get to Greece in a month.
Online parts sites show 3-4 versions of a sensor but no one calls them left side right side or pre cat converter . Do I believe what Mazda says that they have 3 ? If so which is the problem GRRR
Thx again To all. I am getting closer to serenity
PGP :jump:
 

·
Registered
Joined
·
1,822 Posts
if ur car is an i4 and obd1 it should only have 1 sensor on the exhaust manifold if it had another it would be after the cat.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #8
BY I4 do you mean injection 4? It is a 4 cylinder FSO 1A and I think you are right it has only one .
Thx a lot
PGP
 

·
Registered
Joined
·
1,822 Posts
I is short for inline and 4 is the # of cylinders, glad i could help.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #10
Mazda sent me a fax with 4 sensors. I think they are crazy. I have part (MAZDA) #18-861B from them coming out of the exhaust manifold part # 1310. Is there any way to cross check that part # with the Bosch sensor I find online at a site that I will not name as per the rules here !
B 3130-81728 Air Mass MeterBosch $104.60 online numbers
Thx again
PGP:wave:
 

·
Registered
Joined
·
24 Posts
Discussion Starter #11
Disregard what I just sent . That was the MAf not the O2 sensor. Here is info on the online O2 sensor I found!
Catalog part # 250-24068 Replaces:
Bosch 13372
Mazda JE49-18-861, JE49-18-861A, JE50-18-861, JE50-18-861A, JE50-18-861Z, JE53-18-861, KLA6-18-861
Ford F32Z-9F472-A, F32Z-9F472-B
That seems like the right one for $59.95
I hope that cures my problem
Thx again
PGP
 

·
Registered
Joined
·
24 Posts
Discussion Starter #12
To Mazda Moron ,
I replaced the MAF sensor and now the O2 sensor code vanished .Engine is running fine now for over a year.

But now I have a tranny problem.

That site helped me start to diagnose the transmission problem . I was able to draw codes #452 VSS sensor and # 647 3rd gear problem. Thanks a lot for that site, without which I would not have been able to get codes.

I will keep you posted if interested in tranny problem.
Peter
 
1 - 13 of 13 Posts
Top