Mazda MX-6 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
ok first off i drive a '94 mx6 ls, all stock.

first question: I recently installed a new head unit and it has no memory (can't set clock, preset stations etc.) and i know the solution is that the ignition wire and the battery wire are switched but i don't believe thats the problem, (but it could be, i haven't tried it) because when i turn my ignition to acc. I can turn the radio on, any thoughts on this?

second question: I also had to replace my distributor and I noticed after i installed it whenever i turn the car on, it has to crank for a second or two before it actually starts. In other words, it doesn't start right up the second I turn the key. Is this a problem? and if it is, how do I go about fixing it?
 

·
Registered
Joined
·
1,050 Posts
Not sure without more info about the radio. I would check any wires behind the radio with a test light to see if they all have juice going to the radio.

I wonder if your timing is off a hair after your new disty and it is causing the slow starting problem. Check that first is what I would do.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
alright, i'll check the wiring on the radio when i get a chance.
the disty however, to change the timing on it i just loosen it and turn it, correct? sorry im kinda new to working on cars, this is my first car.
 

·
Registered
Joined
·
250 Posts
You can loosen the bolts on the distributor and turn it (change the 'clock'). if you do it while it's running you'll hear either start to die or smooth out. If it's already clocked all the way in one direction and turning it the other way doesn't help you'll have to remove it.
 
1 - 5 of 5 Posts
Top