Mazda MX-6 Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #1 ·
Okay well I just pciekd up my car after having my power steering rack replaced. Now my abs light is coming on. It flashes once when the car starts (i think it used to do this) and then as soon as the car is in motion it comes on and stays on. Anyone have any ideas what could have happened the mechanic said all that was touched was the rack and corresponding wires...any ideas??
 

·
Premium Member
Joined
·
2,347 Posts
maybe he accidentally knoked the wiring on the hubs for the VSS? maybe check all the connections, or even read the codes etc.
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #4 ·
well I picked up a second hand rack off a member here was in GC that cost 100 I think (i forget) then the labour and a few parts such as new belts, repalcement of pump, allignment and new belts came to 350 all up
 

·
Registered
Joined
·
5,273 Posts
on the basic system it could be a fault as a Speed Sensor in the hubs faulty. or the control unit itself, i guess a diagnostic check would confirm this for you.
 

·
Registered
Joined
·
665 Posts
i had a similar problem with my camry
the ABS light came on, and i heard knocking noise

jacked the car up, and the bracket holding the sensor wire was hitting the driveshaft, which caused it to chew the line, hence why the light came on...

check all your ABS sensors and see that they are not torn, or disconnected anywhere
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #7 ·
yeah but what i dont get is before it went into the mechanic i ahd no light on when I got it back theres a light on..what would replacing a power steering rack have to do with abs??? is there a relationship Im not thinkign of somewhere???
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #9 ·
im gonna check that now also Ive noticed after repalcing the rack its alot more diffuclt to turn the car to the right but the left is fine I read soemwhere that the power steering operates off a vehicle speed sensor as well as the abs could the 2 be related..
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #10 ·
ok just went out and checked the bolts holder in the sensor on the left ahnd side werent even hand tight...tightened them up so Ill take hjer for a drive shortly and see how we go..hopefully its such an easy fix!
 

·
Banned
Joined
·
1,755 Posts
please tell me how the vss is related to abs sensors ??? simply, its not, those rings you see along with the abs don't detect speed nor anything like that, if its rotating whilst braking it see it as all good, however if it see that one ring has locked solid the abs unit kicks in. as far as vss is concern, it uses cruise control/speedometer for the vss.
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #13 ·
well just got back from cehcking at that loose bit didnt help anyoen ahve any ideas what could the possibly have kncoked of moved or what could be the probelm??
 

·
Registered
Joined
·
215 Posts
check your abs fuse or relay, start with the basics hey and if you gto any other problems give me a call because i got the mazda mx6 workshop book if you still have any problems becuase i.ve got all the codes and how to diagnoise it, my number is 0413404492
 

·
Registered
Joined
·
3,858 Posts
Discussion Starter · #19 ·
okay Ive doen the obvious looks liek the old girl will eb in for another visit to the emchanic..its obviously speed related cause the light doesnt come on until I start gainign some momentum....
 

·
Banned
Joined
·
1,755 Posts
zorb, damaged abs ring
 
1 - 20 of 28 Posts
Top