Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter · #1 ·
So the other day it was really wet out and I was driving down a bad street and hitting alot of big puddles.. all of a sudden my 4W ABS light came on and stayed on.. I drove for a bit and then pulled over and turned off the car, turned it back on and no ABS light, drove for a little and the light came on.

Left the car alone yesterday, only drove very little, cant remember anything about the light..

Today I was driving for about 10 min when the light came on.. stayed on until i shutdown the car. Turned it back on and no light... So it seems like the light will come on but will reset itself when the car is turned on. Im thinking something happened to the sensor when I was going through all that water the other day.
 

·
Registered
Joined
·
141 Posts
IcEpIc said:
So the other day it was really wet out and I was driving down a bad street and hitting alot of big puddles.. all of a sudden my 4W ABS light came on and stayed on.. I drove for a bit and then pulled over and turned off the car, turned it back on and no ABS light, drove for a little and the light came on.

Left the car alone yesterday, only drove very little, cant remember anything about the light..

Today I was driving for about 10 min when the light came on.. stayed on until i shutdown the car. Turned it back on and no light... So it seems like the light will come on but will reset itself when the car is turned on. Im thinking something happened to the sensor when I was going through all that water the other day.
No, it does that when you have worn out brake pads or low brake fluid. I'd check the fluid and if its not that, get your pads changed and rotors turned.
 

·
Registered
Joined
·
2,664 Posts
Prolly just your brake fluid, I can bet on it. Thats what happened to me.
 
1 - 5 of 5 Posts
Top