Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
Ac works great on the highway. At rest, hardly any ac cooling at all. Pressure are good, about 45 on the low side and 190 on the high side. No leaks. Condensor fan turns on when ac is turned on, blows strongly toward the engine. I recently put on a new radiator. Could the replacement radiator have fins so tight that it prevents air going over the condensor when the car is at rest ? Other than that, I don't see any issues or have a clue.
 

·
Registered
1992, Mazda MX-6 2.5L V6
Joined
·
82 Posts
Could it be a compressor motor issue? I don't know about if the tightly spaced fins could cause such an issue although its odd that it wasn't an issue until you replaced your radiator.
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #4 ·
Checked everything again, don't see any issues anywhere. Lo and high pressure good, right where they should be. HIghway speeds very cool. At rest almost no ac. Condensor fan comes on when ac is turned on. It doesn't run at the 2nd high speed until coolant temp gets way up....my coolant never gets that hot....but I checked anyway, and the 2nd high speed will engage at high coolant temps. Only thing left I can think of is this is a budget compressor, and maybe the more expensive ones do better. I will leave it for now, and save up the money in case I decide to buy a more expensive compressor.
 

·
Registered
Joined
·
34 Posts
get a hose and rinse your condenser well. had a similar issue on one of my cars before. you'd be surprised how much junk is in between those fins. it could also be insufficient cooling like you've said due to different fin design of the new radiator.
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #6 ·
I saw one video where the mechanic cleaned the condensor. He did not open the system. After doing that the hi side pressure dropped amost 55 psi. I am confused about that. The gauge was hooked up to the hi pressure port, which was right after the compressor. How could cleaning the condensor reduce the hi pressure at this particular point in the system....the gauge was reading right after the compressor, before the condensor.....the system was not opened. As a side issue, what in the approximate temperature that it should be at these 3 points......just after the compressor......just after the condensor......just after the expansion valve
 
1 - 6 of 6 Posts
Top