Mazda MX-6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2,459 Posts
Discussion Starter · #1 ·
Well, I searched, got one answer I was looking for, and the other one, I'm lost.

Well, my i4 atx, it's acting up. The O/D light is flashing, which I searched for, and got an answer, but my question is this.

Sometimes when I put the car in park, I hear a grinding sound comming from the shift lock(where you can put the key in) and then, I can put it in and out of park w/o my foot on the brake. But, when it doesn't grind, I have to use the brake to get in and out of gear!

Any Idea's?
 

·
Registered
Joined
·
4,460 Posts
The grinding sound can't be coming from the shift lock area, there's nothing that even moves in that area.

It sounds like you have a problem with the range selector switch, which is essentially a switch that moves via cable when you select various gears. It tells the car what gear you're in and prevents you from doing various things when you're not in certain gears. IE: shifting out of park without your foot on the brake :p

I'd pick up a Haynes manual and get working... not many people on this site care much for attempting to fix the wide array of ATX problems. There's lots of them, they can be complicated... and the ATX sucks :)
 
  • Like
Reactions: Jason

·
Registered
Joined
·
2,459 Posts
Discussion Starter · #3 ·
hah thanks man! I've been looking over my haynes manual, but my pizza is a little more inportnant to me right now.

I'll work on it eventually, but you're right, the ATX does suck!

I figured it wouldn't be so bad.... god I hate driving it! lol that, and it has no power compared to the LS :p
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top