Mazda MX-6 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
618 Posts
Discussion Starter #1
ok im all done except for wiring. i got the big packet of what to rewire but its way over my head. if someone could help me it would be great, i have a few questions. but i dont want the cruise control back in (to much wiring). there is 2 conntectors to the clutch pedal, there was a harness there for one, which one? i dont care about the NPS, unless its easy to wire. I just WANT to know the REQUIRED wiring to get the car to run and drive, etc. the extras ill deal with later or not put them in. THANKS for your help.
 

·
Registered
Joined
·
618 Posts
Discussion Starter #2
Does anyone know??
 

·
Registered
Joined
·
76 Posts
you dont have to do any wiring from the experiences ive had converting car from auto to 5-speed, just jump the park/neutral safety switch and remember not to leave the car in gear. That way any problem you could have would have to be mechanical in nature making it easier to diagnose. As for the cruise control, I would leave it in, isnt it just controlled by vacume hoses?
 

·
Registered
Joined
·
618 Posts
Discussion Starter #4
how do i jump the nuetral safety and park together. and why cant i leave the car in gear?
 

·
Registered
Joined
·
82 Posts
i got the big packet of what to rewire
I'm thinking this might be what u have but just in case here you go, this is for the ls. hope that helps good luck




Electrical
-Plug in harnesses in tranny area.
-Plug in vehicle speed sensor.
-Don’t plug in reverse light switch.. To resolve that, use the 2 wires from the reverse light switch, plug into the to the 1 and 4 for continuity( for the harness in the illustraion below)
-Use 2 wires and jump 6 and 9 to trick the comp, so you can start the car.
-2-3 harnesses do not plug into anything, just leave it

The orange harness that looks like this:
TOP
------------
|1 2 3 4 5|
|6 7 _ 8 9|
-----------
BOTTOM
 

·
Registered
Joined
·
618 Posts
Discussion Starter #6
thanks but no. will someone please help me my dad is now about to tow the car to the junk yard and i just spent around $1500 to do the swap and i already have so much money into the car. i dont understand any of the wiring. i look at all the wires and try to find the one i connect stuff too and its just so many wires. SOMEONE PLEASE HELP!!!
 

·
Registered
Joined
·
618 Posts
Discussion Starter #7
thanks but no. will someone please help me my dad is now about to tow the car to the junk yard and i just spent around $1500 to do the swap and i already have so much money into the car. i dont understand any of the wiring. i look at all the wires and try to find the one i connect stuff too and its just so many wires. I JSUT WANT THE CAR TO RUN. SOMEONE PLEASE HELP!!!
 

·
Registered
Joined
·
29 Posts
ehh what are you talking about?

All the wiring harness plugs (in the engine bay) plug in where they used to except for three of them: One large grey/orange one that used to clip onto the shift selector switch, one big black/yellow one that went to the shift solenoids on the front of the tranny, and one little two prong one that went to some little switch on the driver side of the tranny. The rest of them plug in the same way they used to. The cruise control will work fine with no modifications. You need to use the MTX ECU though.

To get the reverse light to work, run the two wires from pin 4 and pin 1 on the big grey/orange plug to the two wires in the white plug that should be on the front or top of the manual transmission. To bypass the neutral safety cutout (so the car will start), solder the wires that go to pin 6 and 9 together. The pin numbers for the grey/orange plug are as follows....

Looking into the FRONT opening of the plug.
---------------
| 5-4-3-2-1 |
---------------
| 9-8---7-6 |
---------------

Someone else listed the numbers on the forums once before, but it was a little confusing cause the diagram shown in their post was if you were looking at the BACK of the plug (where the wires go into it). It took me a while to figure out why my reverse lights didn't work.... its cause I reversed the wires and actually had wires 5 and 2 going to the reverse switch. (oops!)

The reason you shouldnt start the car in gear if you bypass the neutral safety switch is that if you are dumb and dont push the clutch in while you start the car, its gonna start moving while you're cranking it.

Oh and the clutch safety switches both plug in easily... the plugs already exist on the AT harness (I wonder why though?). I dont know whether or not those plugs actually are wired to anything, so the switches might not function anyway.

As for the three plugs that used to go to the automatic shifter in the center console... just let those dangle. The same with that one big black/yellow plug and the little two prong plug in the engine bay... just let those dangle. They wont be needed anymore @-

Sorry to drag this post up from the dead.... i just had to reply with my .02
 

·
Registered
Joined
·
618 Posts
Discussion Starter #10
still cant find o2 sensor plug. will look more closely in all that wiring.

yea i figured out the 6 and 9 pin. when i tryed to do the reverse light i put it in to 5 and 2 thinkin it was 1 and 4, ill do that to get them to work. thanks for the huge input. im going to put everything back together now.
 
1 - 10 of 10 Posts
Top