Mazda MX-6 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Well, my tranny is gone again, I think.

Here's the symptoms.....

Dash guage only shows up "S" on the gear selector.

When car is in regular drive, there is NO POWER and only has 3 gears.

Sometimes the shifter needs to be pulled out of park, then back into park before the starter motor will kick in.

CHECK ENGINE light comes on and off with no pattern whatsoever.

HELP!!!!! has this happend to anyone else out there? My feeling is that I will need to have the gear cable adjusted but I don't want to get screwed again by PRO MECH Auto, located in North York at the #400 and Steeles area, (Ontario Canada). They rebuilt my tranny (under warranty from seller....ONTARIO AUTO, located at Finch south of Steeles, North York, Ontario Canada) in September last year. So far, I have had the car in for 5 visits to fix the bloody tranny. They tell me that the tranny is hard to fix, but that is not my problem. If they weren't qualified enough to have fixed it in the first place, they should not have taken my money. (Warranty covered only $700.00 of the $1800 job!) The kicker is that PRO MECH Auto was the only shop who was authorized to do the tranny work in the warranty)

Anyway, everything is documented and I have had an initial interview with the staff for the Peter Silverman Show (consumer watchdog for national television network), I am just waiting to see if my connections in the media will hook me up.

So, after that vent, any ideas on what the hell is wrong with it? I would take it back but I refuse to go back to that "shop" for anything.

Any advice would help as to what the problem might be.

Thanks everyone! I am always here to see what is going on! (If only I could remember what my old login name was!!!)

Sincerely,

Steve
 

·
Registered
Joined
·
806 Posts
Not having an atx, I don't have much advice except for people have gotten more reliability by adding a tranny cooler. For your sporadic CEL light go to http://home.golden.net/~trinity/ , click on Malf Codes and pull the code/s so you will know what is making the CEL light.
 
1 - 2 of 2 Posts
Top