Mazda MX-6 Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #1 ·
Hey,
So I've searched the forums far and wide, and I've done almost everything that they've said to do. My next step on my 89 626 GT is to start all over. The driver's side seatbelt intermitently (not sure on spelling?) and more often that not, it doesn't work at all. Any ideas on what else I could check? I have the factory manual and it has been very useful, but my car needs to pass inspection within a week and we're running out of ideas here. Thanks!! :) Karma to any that help; as always.

This is over in the electronics section, but I figured that more people visit this forums :)
 

·
Registered
Joined
·
2,419 Posts
Im not sure about that system at all, to be honest. But check whatever fuse or relay is part of that system and maybe replace it. If it is intermittent, then it is more than likely just something loose like wires or bad/loose fuse/relay, whatever it has? Sorry im not much help.
 

·
Registered
Joined
·
3,363 Posts
vrouv06 said:
mine was doing that so i took it to mazda and all it needed was some good old fashion lubing
How much did they charge? Some say they are supposed to do it for free but that's never been the case when I talk to mazda themselves....
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #5 ·
retsamaksrepus said:
How much did they charge? Some say they are supposed to do it for free but that's never been the case when I talk to mazda themselves....
That's what I'm wondering too . . . I've heard some people saying that they've gotten it done for free.
 

·
Premium Member
Joined
·
5,011 Posts
i thought mazda only worked on the auto seatbelts where it clicks in at the top (the red button doesnt safely lock the belt in??) my belts seem to slowly be going out, they only like to work sometimes. Ive noticed it's worse when the weather is cold out here...........karma for anyone who can help me as well
 

·
Registered
Joined
·
1,434 Posts
well I brought my car in because my AC fan wasn't working well and they replaced the fan and i mentioned the seatbelt was fucked up and they lubed it up. I didn't see any seatbelt service charge on the reciept soim asuming it was free
 

·
Registered
Joined
·
137 Posts
If you live in a place where it snows, most likely it is getting cold. The sensor in the door getts all crudded up. Take PB Blaster and spray it into the actual door lock part. Not where you put your key, but where the striker hits in the door jamb. Then, open and close the door about ten times. If the problem isnt solved, then you are screwed. This is a yearly thing for me. Good luck


PS: take silicone spray or white lithium (messy) and spray it in thetrack. this will prevent any junkyard runs.
 

·
Premium Member
Joined
·
5,011 Posts
i noticed today while getting in and out of my car this morning, the belt wouldn't move forward if i opened the door from the outside........but worked everytime i pulled the handle from the inside :confused:

i'm gonna pull it apart once i get the chance and do some investigating
 

·
Registered
Joined
·
1,605 Posts
Discussion Starter · #12 ·
Thanks guys.
I'll be checking the connections this weekend (good thing for the shop manual) and hopefully it won't be the control unit. I'll let you guys know what happens :)
 
1 - 12 of 12 Posts
Top