Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
932 Posts
Discussion Starter · #1 ·
Well I finally got the car running after the I removed the intake manifold again and put it back on. The throttle body gasket was shot and leaking really bad so it wouldn't idle. So I started driving home from my friends house and everything was fine then all the sudden the thing backfired and wouldn't go anywhere, I would push the gas and the thing and it wouldn't idle it would start and then just fall on it's ass. So I pulled over to the side of the road and trained to crank the thing over again and it starts and just dies. I don't what the hell is wrong with it. I've researched the site quite a bit and all I can find is people talking about the distributor. But why the heck would my distributor go bad if I didn't even touch that part of the car?

Please help I miss my car!
 

·
Registered
Joined
·
5,550 Posts
It wil be either an air leak or the VAf or perhaps it has become unplugged.. or is faulty.. at least it is not measuring the airflow into the motor..
I would firstly look at the electrical.. conection
 

·
Registered
Joined
·
141 Posts
It could very well be a bad disty, they take ****s when theyre worn down like most things;) , ive had mine replaced, how many miles is on your car?
 

·
Registered
Joined
·
932 Posts
Discussion Starter · #4 ·
I have 92,000 miles the only problem is I usually work on my car by myself if I had someone else turn the key I could probably see what's going on. But from what I can hear I can hear some kind of vacuum line is screwed. It's just a little weird it runs fine for like 7 miles then all the sudden goes to hell. What about the intake manfold gaskets if their share and air is leaking in or out would that cause it to backfire.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top