Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
my mx6 won't start...i have come to 2 conclusions

i am a noob so bare w/ me...

1) my battery died...btw...how da hell do i tell if its dead or not?

2) my battery terminal is too loose (iono if da will actually a problem), i hooked up my amps to the battery and accidentally took off the whole terminal and it doesn't tighten anymore

can anyone suggest what else might went wrong?

theres no noise when i try to start it again after it failed already...seems like all power cuts off if the first try doesn't work...
 

·
Registered
Joined
·
2,602 Posts
did you try to jumpstart the car?
 

·
Registered
Joined
·
787 Posts
Sorry, but it's F*ing painful trying to read your post , between missing words, lousy spelling, and web shorthand. More people might respond if they could understand you.
I think you said that the battery connection cables were loose and you cant tighten them. You either need new connection clamps on your old cables, or get new cables. These must be tight on a clean battery post, and the battery must have the proper power. Take the battery to a parts store and have it checked. While you are there get new cables to fit the battery. Take your time and hook it all up correctly (you might want to mark the old ones with tape and what goes where; judging by your post you may forget where everything goes).
 

·
Registered
Joined
·
2,116 Posts
do like lordy said.

when i got my mx6 i had that exact problem and it was just a loose battery terminal connection. try twisting and pushing down on the terminal connection to snug it down, its tappered a little bit i believe.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #5 ·
ya sorry about the crap english...not really good on the grammar

thx alot 4 the help, i figured that it was the stupid loose battery terminal because after i twisted it a few times the car started perfectly fine again

i think i just need new battery cables...few questions tho...once again i am a noob so bare with me...

1) sumone said it helps to put sume eletro gel or whatever u call it to keep the terminal at its optimum condition?

2) can i get new battery cables at canadian tire? and is it hard to install? how much are they? (tell me if u give me US dollar cuz i live in canada)

any help is appreciated :)
 
1 - 5 of 5 Posts
Top