Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter · #1 ·
I recently had to boost my car because I left the headlights on....afterwards I notice that the check engine light goes on more frequently and the rpm will go below 1/2k and sometimes it will shut down (the car). When I got the battery checked, the reading was 100% but is it really? Or does my battery need charging? Doesn't the alternator charge it sufficiently after 15miles????

PLEASE HELP ME OUT!!!!!! before i go out and buy a battery.
 

·
Registered
Joined
·
806 Posts
Battery Charge Test

If you have a multimeter, measure across the poles of your battery in the 20V range and you should see in the range of about 12.7V if the battery is good. With the car running and the RPM's up a little you should be able to see about 14.5V across the battery if the alternator is charging. Check these two and you should be able to tell if the battery is charging, not holding a charge, etc. If your check engine light is coming on, that says a code is put in the system, pull it and see what it is.
 

·
Registered
Joined
·
488 Posts
Disconnect the negative cable from the battery, press on teh brake pedal for 15 seconds, let the car sit for 15 minutes, reconnect the negative cable to the battery, then start the car and let it idle for 5 minutes. Thsi will clear any codes that you have and reset the ECU. You may have just spiked the ECu slightly when jumping the car, this will help clear out any false codes that the ECU might be throwing out.
 
1 - 3 of 3 Posts
Top