Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys, hi i'm new in here and have a really big problem, the problem is that i can't start my car, I tryed to change the distributor, and even the hei mod, nothing happened, the car still won't start!!! I have no more ideas, can you guys out here help me please!!!:wave: thanks -Mat-

my car is an mx-6 93 auto tranny with the 4 cylinders
 

·
Registered
Joined
·
2,714 Posts
The engine cranks (turns over) OK, I take it?
Have you checked for spark, by removing a spark plug and laying it on the block?
Have you checked to see if the timing belt is broken, by removing the disty cap and seeing if the rotor turns when you crank the engine?
Did the car shut down while you were driving, or did it just fail to start one morning?
Had you been doing any work on the car immediately before it failed to start?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Ok so, first of all, the engine cranks, so it try to start but i have no spark at the end of a spark plugs wires, the timing belt is fine and I check it out so all is fine on this side...the rotor turn in the disty, The car didn't want to start one morning... The only thing that happened to this car before it won't start is that someone crash into it ,like just bump the front of the car, the car is fine, engine too ,the only damage it took was a little bit of scratch on the front bumper... So i don't see what the problem is? I'm going to see for the position crank sensor... thanks for the issue!!!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 · (Edited)
Ok euh...I'm probably stupid or noob but I don't see any crankshaft position sensor on the 1993 mx-6 4 cylinders engine... Probably only the 6 cylinders have one or maybe i'm just stupid and didn't find it at all??? So I have no ideas what the problems could be!!! I tested my wires and they are all ok!! there's voltage at the distributors but the distributors won't give fire!!! i'm all messed up!!! I can't find that damn problem !!!! Any help would be appreciate!!! Thanks -mat-
 
1 - 5 of 5 Posts
Top