Mazda MX-6 Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
hey, so im the very proud owner of a shotbox 93 mx6. 5 speed, 155k miles on the frame, about 60k on the klze engine i dropped in at 145k miles after blowing a headgasket, overheating it, and snapping a valve spring. but anyway, today i was driving it back from the bank and it shut off while in gear. didnt want to start back up again when i popped the clutch and turned the key. so i roll started it as i was still moving. started back up again, but i heard a real loud pop and the exhausted sounded different. get back home 3 miles away (only reason i drove it back) and look under and the cat is just split in half down the middle. any idea why it may have shut off or why it split the cat? im running a lil rich because i melted off an o2 sensor but other than that was running fine before today.. i have a megasquirt 2 plug and play i need to install along with a quad spark, trigger wheel, and a coil pack for stand alone efi and ignition timings, im just waiting on being able to afford wideband sensors.

any help would be greatly appreciated, thanks
 

·
Registered
Joined
·
2,446 Posts
Melted off an O2 sensor? I have made turbo's turn red/white hot to the point you can see the shadow of the exhaust turbine wheel through the Iron housing and blasting all this heat onto the O2 sensor inches from the turbo but never saw one melt.

I can't say for sure if your O2 sensor melted into the cat and blocked it or if while the O2 sensor was melting the cat was as well. I would say your cat block up and stopped allowing exhaust through it and choked out the engine. When you started it on a roll the air pump (engine) produced enough pressure to blow out the weakest area in the exhaust.
One other possibility is that an injector is sticking opened and enough gas pooled in the cat to block it up, when you started it on a roll the pressure and heat at the cat where enough to auto ignite the fuel vapor in the cat.
 
1 - 2 of 2 Posts
Top