Mazda MX-6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
I've had a broken engine mount ever since I bought my 6 2 and half years ago. Never got it fixed but my shifter rattles/shakes a lot when i'm driving...there's a lot of vibration...hasn't really caused any problems just is a nuisance...but one day i breaked really hard and my engine turned off...is that because of the broken engine mount? i was thinking of replacing my engine mounts since the urthane ones came out...but i'm reading that we have more than just the front and back ones...so maybe anothre engine mount is broken? but since my shifter is shaking the rear one which olds the trans must be broken? i dunno if i should replace it since i'm a broke college student and i only drive the car when i'm back home in the summer
 

·
Registered
Joined
·
271 Posts
what damage can be caused really depends on how worn out the mount is. the rocking back and forth of the engine and tranny can eventually break the other mounts. or like it did to my moms ford taurus....i know its not a 6 but the same instance.... it cut into the power steering lines. the pump for that went. then started cutting into other stuff and eventually we had a lot of damage on our hands. replace them when theyre worn or broke as soon as you can afford them... dont waste time. plus you loose so much hp to the wheels from the engine and tranny rocking back n forth that could be allowing you that little extra to beat that one car.
 
1 - 3 of 3 Posts
Top