Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
i have a 93 mazda mx6 4 cylinder
on the way home from work, i notice my charge light on and my rear light light was on and i notice my temperature hand was pass the h it was supa hot. im talking not even 5 minutes outside of work. my check engine light came on and then it went off.
what do you guys think is wrong with my car?
thanks for the help guys
 

·
Registered
Joined
·
2,064 Posts
Your alternator is not spinning if the charge light is on. I'm not sure if that belt drives the water pump, but it sounds like you broke a belt.

Tyson
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
thanks guys, i just checked it. the alternator belt broke, i dont know if that goes around the water pump or not. do you guys think i did damage to my engine? the engine sounds fine when i start it up. no leaks or anything. and im like a quart low on oil. i have a really nice car so ill have to post pics.
 

·
Registered
Joined
·
3,092 Posts
YEP!!! it drives the water pump too... its pretty easy to replace and you should do your PS/AC belt while youre in there. i dont think you damaged the engine TOO much... maybe the cylinder head a little. it might be a good idea to pull your plugs and check them too. you will most likely have to replace them...
 

·
Registered
Joined
·
305 Posts
As for the "rear" light, that's unrelated. It comes on when you've got a blown tailight bulb. Unfortunately, the only way to know which bulb it is, is to take off your taillights, and have some one depress the brakes, while someone stands behind the car to check which light it is. Good Luck.
 

·
Registered
Joined
·
3,092 Posts
why take off the housings??? just have someone press the brake or jump the pins on the pedal switch...
 

·
Registered
Joined
·
921 Posts
ALso check the bearings on the tensionor pulleys. SOmetimes it seizes and cause the belt to snap.
 
1 - 8 of 8 Posts
Top