Mazda MX-6 Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
Hey guys I got a 93 ls, Just droped a PGT engine in. Other than High idle issuses and cant shift into gear all is fine :( :).

I can put the car in gear when the engine isnt running. ( Is Manual Tranny)
When i start car and press the clutch its like i dont have the clutch pressed in and peddle is really weak on pressure. I replaced the slave cyl, and did bleed the lines a few times to where is "seems" only fluid is coming out and no more air. The clutch is new and worked fine on the old engine. The master cyl is stock on car but worked fine on the old engine (albiet it has been 2 years since it was last driven). I dont really see any loss in fluid and all lines are stock as well. Any thoughts??
 

·
Registered
Joined
·
250 Posts
I had a similar problem on mine. There's a push rod that goes through the firewall and is connected to your clutch pedal. Adjust this so that it is longer, or as long as possible. This may fix your problem. If you need more info let me know.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #5 ·
thx for reply dave :)

Yeah man if you could gimmie a detailed descrip. on how to adjust this rod ill be very gratefull. I have a haynes manual and dont see a section for this rod u speak of. only thing im familiar with is just the lines. what does adjusting the rod do? all more for to be applied to the lever going into the tranny?
 

·
Registered
Joined
·
40 Posts
You sure that the thrust bearing didnt fall out? I also had a high idle problem with my last mx6 and I ended up replaceing the throtle positioning sensor.
 

·
Registered
Joined
·
2,227 Posts
i had a similar problem when I had my ZE put in. The car would go into gear when not running, but wouldn't go into gear when the engine was running. Replaced the slave cylinder, master cylinder, bled the lines like crazy, no good. Replaced the Throw Out Bearing and still no good. Was using a new clutch made by ACT and turns out there was something wrong with the pressure plate, or the plate wasn't for the mx6 (even though it was sealed with the part numbers for an mx6). Ended up buying a clutchmasters stage II clutch and all is well
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #9 ·
maybe the trow out bearing? I can easily wiggle the rod that the slave cyl pushes, it doesnt seem "tight"/
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #10 ·
is there a way to maybe re position the throw out bearing w/o taking the tranny off? if its not my master cyl or lines what else could it be? my clutch is new.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #11 ·
ok WEIRD! I was fixing some little ods n ends on car tighting up exhaust etc...
I Started up car to run for a bit and i could easily switch gears! So..... I decided to take it around the block and about half way back I couldnt switch any more I basically had to force it into gear, I almost thought i wouldnt make it back home :(, but i did :). Does this give any indication of what might have went wrong? Before I left I did pump the clutch for like 10 min.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #12 ·
Anybody have an idea of why the clutch work for a min. and than stop???
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #14 ·
i have checked and im almost 90% positivw it isnt leaking i pumped it for like 10 min and no change in fluid lvl. :(
 

·
Registered
Joined
·
2,227 Posts
i suggest replacing your master, bleeding everything again. if that still doesn't do it, it'll be drop the tranny time and check everything. you should take a look at your flywheel to see if there are any heat marks. all that forcing of gears can't be good on your tranny
 

·
Registered
Joined
·
737 Posts
there doesn't have to be a leak for a master or slave to be bad. if the secondary valve have failed then the cylinder is no go. you keep all your fluid but it just gets pushed around inside the cylinder instead of staying in its corresponding galley and moving the primary vale.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #17 ·
i havent drove the car since this happened from fear of damg. to tranny. I did replace the slave cyl, it was rusted to crap when i tryed to blead it the bleeder valve broke off lol. So i do have a new one. Where is the Master Cyl located, the haynes manual doesnt specify to clearly?

So should i replace the master? it has nvr been replaced before.
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #18 ·
is the master brake cyl the same as the master clutch cylinder located under the fluid container?
 

·
Registered
Joined
·
224 Posts
Not such a quick shift any more huh? Sorry had to supprised I'm re first to notice thAt hope u figure it out
 
1 - 20 of 21 Posts
Top