Mazda MX-6 Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
so i freshly rebuild my motor and it started all fine ran quite well... then i went for a stroll down the road and blew one of my ic pipes of at one psi, spring was too hard in the BOV. so in th middle of no where i start to dig under the hood till the cops come to get out of there. come to find out yeah one ic pipe blew and my hose to my MAF was not tight so i did that and it started. the thing is it ran or idled atleast at first but under acceleration i could not give more than like 15percent throttle. i checked my piping like literaly ten times atleast.

one more question, when running cold air intake the stock vacume hose that attaches to the air box. whats up with it? do i have to make a fitting and connect it? i am runnin the t-bird set up on it if that help any. stock rebuild. (factory parts) and its a turbo model 1989.


thanks,
 

·
Registered
Joined
·
3,379 Posts
check the ic for cracks, it still sounds like an air leak. as for that hose just let it vent where ever or you can make a fitting to reattach it. it a vent for egr or some shit.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
problem solved.... lol when i took it out for the first drive i then put it in the shop and took out one of the springs in my BOV. i had two and it was way to tight for such a small turbo so the vacume was actually sucking the BOV open. simple but unexpected.
so i have to hook up a boost line to the BOV not a vacume line yeah? makes sense cus boost will keep it down un boosting conditions. am i right?
 

·
Registered
Joined
·
234 Posts
problem solved.... lol when i took it out for the first drive i then put it in the shop and took out one of the springs in my BOV. i had two and it was way to tight for such a small turbo so the vacume was actually sucking the BOV open. simple but unexpected.
so i have to hook up a boost line to the BOV not a vacume line yeah? makes sense cus boost will keep it down un boosting conditions. am i right?
You should hook up the factory vacuum/boost line to the bov. Problem solved
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
ok so i did that and it idle really nice anc drives nice but once i get to about 4 pounds it starts to jerk and all. sounds to me like the BOV is openin to early. one more spring needed in it?
 

·
Premium Member
Joined
·
18,203 Posts
put back on the stock bypass valve and check your throttle body boot, report back.
 

·
Registered
Joined
·
419 Posts
ok so i did that and it idle really nice anc drives nice but once i get to about 4 pounds it starts to jerk and all. sounds to me like the BOV is openin to early. one more spring needed in it?
If you get a chance ask maffatato15 about it. Hes a 1G member on here who has messed around with blow off valves. If I can remember correctly he had a similar problem.
 

·
Premium Member
Joined
·
18,203 Posts
If you get a chance ask maffatato15 about it. Hes a 1G member on here who has messed around with blow off valves. If I can remember correctly he had a similar problem.
I have to...well haven't messed around too much. I bought quality and stuck with it. OP should try an HKS SQV or SSQV. Not the silly knock offs because they aren't worth a god damn.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #10 ·
well, i have a full 2.5 in IC piping set up and a custom pipe running from the t-bird turbo so it would be a lil pain to set up the stock miniture BOV. i was thinkin a SRT-4 resirculation valve. they sound good and imagine are big too. as to my throttle body seal..... im running gasket maker on it now cus my so called full gasket kit never came with the throttle body gasket. but trying not to boost now while breaking in the engine for the first 1500 miles or so so i figured that would not be a prob. ill get one asap.
 

·
Premium Member
Joined
·
5,011 Posts
better fix your problem first, then flog that motor to get those piston rings to break in as good as possible!
 

·
Registered
Joined
·
234 Posts
i was thinkin a SRT-4 resirculation valve. they sound good and imagine are big too.
The stock srt4 bov is part of the compressor housing if im not mistaken. You wont be able to use it unless you use the turbo too which you cant do cause the exhaust housing and manifold are one piece. Very odd design but it works.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #16 ·
its a type XS bov. got it to owrk. sounds good must of had the wrong line runnin of it had a leak because i replaced the line and connected it to a diff tube. but i got oil in my IC piping, the turbo i bought does not have many miles on it just it was sitting around in a shop for like 10 years so im thinking the seals are bad. any corrections?
 

·
Premium Member
Joined
·
18,203 Posts
it's normal. blow by enters the intake system before the turbo. there's a line that comes off the valve cover that connects to the intake behind the vaf.
 
1 - 17 of 17 Posts
Top