Mazda MX-6 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 · (Edited)
car died??? distributor??

ok this is what happen... i was driving on the highway then all of a sudden my car dies. the rpms just dove straight to 0. then when i was on the side of the road trying to restart it, it would churn, but it wouldnt start. after like 20-30 minutes i tried to start it again.. and it grabbed... so i drove like 5-7 miles.. then the same thing happen.. the rpms just dived and the car died... so about 30 minutes later someone gave me a jump, and after about 4 attempts it started up and i made it home (15-20 miles). i dont think its the battery or alternator... so do u think its the distributor?? or what else? Thanks.
 

·
Registered
Joined
·
265 Posts
Confusing. Why did you jump it? Is your battery weak?

It sounds like the disty. When the coil gets hot it kills and wont start until it cools a bit. If jumping it really helped then it should be a battery/alt problem. I'd guess the jump was pointless and you have the disty prob.

Go to local parts store to check battery and alt, and if they are good I would fix the disty.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
yea im not sure if the jump made a difference at all... because as i said.. i was stopped for like 20-30 minutes and then i tried again and it started... so that was probably the reason why it started the second time as well.. and just a coincidence that it happened while jumping it... because as the cables were connected i tried starting it several times and still nothing.. but then on like my 4th or 5th try it started... but i was kinda thinking its the disty as well..
 
1 - 4 of 4 Posts
Top