Mazda MX-6 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
i live in wi and right now its cold. durring the day i was driveing about 50 mph and my car just died. i just pushed in the cluth and let it out in 5th and started right back up. Then that night it was about 2degrees and i was driveing every thing was fine. the car was warm. I pulled over to the side of the road to drop some one off and then my car just died. it turns over but wont start. my batt died from trying to start it. i have a klze with the old ecu. i have a cai and the throtle body bypass mod so now i have no antifreez to warm up the throtle body. The colder it gets out side the shittier it will run even if the car is warm. plz help. Is it to cold for the throtle body bypass or what
 

·
Registered
Joined
·
1,503 Posts
Get a battery and go from there. if that solves it then your battery had a low charge and couldn't handle the low temperatures. If it keeps doing it check the alternator.

karma if it helps?
 

·
Registered
Joined
·
12,045 Posts
Pull your codes (even if you never saw a CEL).. sounds like your distributor might be on it's way out since you're running a normal DE one.
 

·
Registered
Joined
·
351 Posts
my disty went bad almost the same way.
only thing differenent was that my car died and never started again.
With road-assistence we starten to check spark and fuell pump untill the batt. was empty.

Conclusion , disty needs to be replaced
 

·
Registered
Joined
·
50 Posts
Same problem with my old MX-3. We were out in the middle of no where and it just died. After hours of work we finally changed the disty and it started right up.
 
1 - 5 of 5 Posts
Top