Mazda MX-6 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
321 Posts
Discussion Starter · #1 ·
Hi all,

I have a problem with my Six. I bought it about two months ago after which I had a full service done. Everthing was checked out and in perfect condition. When I am driving normally eg. 40mph and I have to slow down a bit because of a small bump or someone in front of me is turning, I do not need to break since the 2.5l V6 manual is very flexible in the gears, all I have to do is take the foot off the accelerator, then when I need to I put it back on again (every single technical guy here said that's fine, no gear drop needed due to flexibility). But, when I do so, the car jumps a bit, as if it expects continuous accelerator, and when I put my foot back on (no matter how slow/gentle its done) it jumps a bit again. I have tried dropping everytime i need to slow down, to eg. 2nd gear, but it seems to be doing the same thing. The engine has no mods yet, its stock.

Any advice would really be appreciated!! Thanks All.
 

·
Registered
Joined
·
114 Posts
i have the same problem also...... i feel u....... :(
 

·
Registered
Joined
·
41 Posts
TPS= Throttle Position Sensor
It is located on your throttle body. I had a surging problem associated primarily with the lower gears and once I had adjusted it I was fine.
It could also be your plug wires.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top