Mazda MX-6 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
CAN ANYONE GIVE ME A IDEA ON WHY MY CAR IS STALLING AT
THE STOPLIGHTS AND STOP SIGNS . IT STARTS RIGHT BACK UP AND THEN RUNS FINE . THIS HAS HAPPEND 2 TIMES IN TWO WEEKS
AND THEN YESTERDAY WHEN SLOWING DOWN FOR A SIGN THE CHECK ENGINE LIGHT CAME ON FOR A 10TH OF A SECONDTHEN NEVER SEEN IT AFTER THAT. MY CAR JUST TURNED TO 98,000 MILES
PLEASE HELP THANKS ,
BOBCATT.
94 MX6LS
 

·
Registered
Joined
·
179 Posts
mine does that too, but I havn't found a vacuum leak yet. I'm not sure yet. I am gonna pull the codes and see if it tells me anything, mine has 117,000 miles on it.
 

·
Registered
Joined
·
47 Posts
Sounds like a vacumn leak to maybe the oxegen sensor. Happened to me but after i started it again the rpms droped below 500 so yeah probably vacumn
 

·
Registered
Joined
·
3,167 Posts
Well, most of the posts are pretty much focusing on a vacuum leak and that sounds pretty reasonable as a starting point for diagnosis.

Bobcat69, what happens when you do this: start the engine and let it get nice and hot. Turn off all big electrical loads (heater blower, rear defog, headlamps etc) and ground the TEN pin in the Diagnostic box (see my web site under Malf Codes for a legend if you aren't sure). What does the engine idle do? Does it go really low? Really high? Stay about "normal"?

Turn off the ignition till the engine stops and then turn the key to run (don't start it). Do the cooling fans come on? If not, crack the throttle ever so slightly...do the fans come on then?
 
G

·
Stalling at stoplight, restarts no problem

Great site, Mike's website terrific. I have same problem with same car. Did Mike's suggested test, grounded TEN when engine hot and idle increased from 900 RPM to 1200 RPM. Does that help with diagnosis? Many thanks.
 
1 - 9 of 9 Posts
Top