Mazda MX-6 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
Okay heres whats going on... I have a 93 manual ls When sitting at a light my car idles at 750 maybe a little higher. then it drops to about 500 or lower and in some cases it stalls unless i rev the engine to over 1k for a second. I dont know what the problem is, but it doesnt stop there. On acceleration the car drops in rpm and bucks like it does if you drop the clutch and its about to stall out. It does this only in low rpm. Also when starting up it takes a little to turn over sometimes and sputters during first rev. There is no check engine light triggered it has coolant and the oil isnt low. What do you think it is?
 

·
Premium Member
Joined
·
597 Posts
Heres a few things you may want to check.
- Fuel Filter (cheap)
- Fuel pump relay
- Vacuum Leak
- TPS
- Distributor Components dirty (rotor, rotor button etc), Spark wires and plugs

In my experience a clogged fuel filter did the same thing to me. Its not a hard repair either.

Hope this helps a bit. Im logging off but im sure others will be happy to help. Good luck!
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #3 ·
thx hopefully its something like that everyone says Cumberland farms gas is dirty lol
 

·
Premium Member
Joined
·
597 Posts
Yeah cheapo gas can clog them filters up man lol. Word of advice: NEVER get gas in Mexico. Ive seen mayhem lol
 

·
Registered
Joined
·
69 Posts
Discussion Starter · #5 ·
well the problem is fixed. Wasnt the fuel filter it was one or more of the spark plugs. Now the mx6 is running smoother and starts up on a dime
 

·
Premium Member
Joined
·
597 Posts
Again, glad to hear it was something simple. Bright side is now you dont have to worry about the filter! :tup:
 
1 - 6 of 6 Posts
Top