Mazda MX-6 Forum banner

1 - 4 of 4 Posts
G

·
Discussion Starter · #1 ·
I have had my Centerforce Dual Friction clutch for a little under 5 months now and it seems that it is already slipping. When i shift it stays at high RPMs for a second then drops. I can really feel it slipping at high speeds in 5th such as at 70mph when i am trying to pass. Also i can't chirp my tires from 1-2 gear if my life depended on it, when i first got the clutch i could definantly chirp 1-2 and sometimes 2-3. But the wierd thing is that i don't smell that burnt clutch smell. I don't run my car hard that often. And yes i did break it in for over 500 miles when i first got it. Someone tell me what is going on here. I had better not have spent over $280 on a POS clutch plus another 200 for installation!!! :(
 

·
Registered
Joined
·
488 Posts
Unfortunately that seems to be a common complaint with most of the Probe members about the Centerforce clutch, which is why the ACT one is so popular even witht he adjustments to the clutch pedal and hard engagement.
 

·
Registered
Joined
·
193 Posts
someone correct me if I'm wrong but I thought part of the slipping problem with stock was the weak pressure plate. If you don't change the pressure plate then it may just slip with whatever clutch you put in. There was just a bulk buy couple months ago on probetalk and the ACT Street clutch came with a new pressure plate. I haven't installed it yet, I promised to teach a couple friends how to drive stick before I do (smile).
hr
 
1 - 4 of 4 Posts
Top