Mazda MX-6 Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
Im new to the forum and I was searching for a cure to a problem that arises with the check engine light, but i didnt find one. Maybe someone can help. When I'm traveling at highway speeds 70-75 and I accelerate to pass, I reach above 80 mph and then slow back down to speed my check engine light will come on for about 10-20 seconds and then go off. Does anyone have a suggestions on what might be wrong. Lack of air, to much fuel, bad o2 sensor?
Very annoying problem!!
 

·
Registered
Joined
·
32 Posts
Try going to the 'Frequently Asked Question, 2 G' section. Pan down until you find how to run the codes. I just looked at it so its still there. It has a list of each code number and what each means.

Jim D
 

·
Registered
Joined
·
112 Posts
I think he needs more then this, i mean, you cant even pull the code out of the car to check it since it turns on and off when driving *bummer*. Though i dont know what to tell you, you might (untill some one who knows what their posting speaks up) call Mazda to talk to a service adviser. Note: Dont let him talk you in to bringing the car to them, just see if he has any tips to look in to.
 
G

·
Discussion Starter · #5 ·
Thanks for the help guys. Here is what I pulled from the codes. The first one was a 24, Right O2 sensor. I figure I should replace both while im at it. The next code was a 41 which corresopnds to the VIRS #1 solenoid. I found a post where they recommended replacing the solenoid with the FPRC solenoid. In the process I broke every connection for the vaccuum lines. oops! So now i have the FPR not connected at all. Is that bad? But the VIRS seems to work now! Thank goodness I didnt break the good one.
Does anyone have a clue on how much these solenoids cost?
 
1 - 5 of 5 Posts
Top