Mazda MX-6 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Could someone help me?
Nearly everytime I drive my MX-6 ('94 LS) the check engine light comes on for no apparent reason. It doesn't seem to affect anything. Does this happen to anyone else? What could it mean?
 

·
Registered
Joined
·
2,064 Posts
Chances are it's one of the two oxygen sensors.

Since you have a 94 you can obtain the code with a paper clip or a short piece of wire.

Turn the car off. Open the diagnostic connector under the hood (next to the battery). Put one end of the wire in the GND and the other in TEN.

Turn the ignition switch to on. The light will blink. A long blink is ten, two long blinks twenty, etc. short blinks work the same way, only for the second digit.

It will give you a code. I can look those up for you or you can get them from the Haynes manual, which is pretty good for these cars.

Tyson
95 LS (for sale)
 

·
JDM Conversion
Joined
·
522 Posts
I had that happening to me, the check engine light coming on quite often, but always only for a few seconds and then it would turn off. When I took it to my dealer they changed both O2 sensors. Anyways, that was the problem on mine ('94 LS) Good luck.

bj
 

·
Registered
Joined
·
2,064 Posts
Also, if it's the oxygen sensors, I'd shop around.

I recall reading that Bosch sensors were good. My experience was that the Ford dealer (PGT) wanted $300 for the sensor. The Mazda dealer wanted about $120. Autozone (Bosch) wanted $69.

But you have to make sure that you get the one that does not have to be soldered on, unless you like soldering.

Tyson
95 LS
 
G

·
Guest
Joined
·
0 Posts
engine light on

Try just getting a trans job (fluid, filter, etc) My 95LS gave me the same crap and it never comes on now
 

·
Registered
Joined
·
2,064 Posts
The transmission job should not be related to the check engine light at all. Read the Haynes manual or the factory manual and they tell you exactly what will trigger the light.

Tyson
 

·
Registered
Joined
·
78 Posts
I bought my '6 a year ago, and that light has been on since ive had it. i had it checked and they said everything was fine, so i dont know what to do, i guess just change everything in the whole car....at least nothing bad has happend in that year :)
 
1 - 8 of 8 Posts
Top