Mazda MX-6 Forum banner

1 - 10 of 10 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
ok... now i have a tricky one for you all - i've been through all the posts and can't seem to find referance to this particuliar noise...

when i pull up to let the car idle down i am getting this noise sometimes - especially after i have been driving it hard...

it sounds like a fuel injector 'click' but much louder, and not in the same rythem - slightly out of sync... maybe a misfire or something?

i do have a very bad exhaust manifold leak - but its not that noise - i know what its like.... and besides it goes away once the cars warmed up - and the car is bloody hot by this point.

listenin to the exhaust it seems 'lumpy' for lack of a better description... like a cylinder isn't firing...

could this all be a valve? or something up with my ignition?

its drivable - goes as hard as ever... but really wants to stall when its idling like this...

it always get regular fluid/plug/leads changes...so i doubt its that...besides as i said earlier its not constantly like this..only after hard runs/high boost...

*begs on hands and knees* PLEASE HELP

its just so damn annoying...
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #2
oh yes, and when putting a screw driver to the engine to listen for noises i can't seem to find where its comming from - i think its under the rocker cover or the intake manifold... its strongest there
 

·
Registered
Joined
·
1,601 Posts
Sounds like you have an HLA (sometimes called a lifter) going bad. You can get replacement ones for about 10-20 us. You will also need to replace your valve cover seal since it is under there. Do a search on HLA's here or on www.probetalk.com and you will find the fix.
 

·
Registered
Joined
·
539 Posts
Funny that you would mention a clicking noise. I finally got my car back last week after having my turbo rebuilt and now it's making a weird clicking noise whenever the engine comes on boost. The noise wasn't there when I first got the car and the week that followed but just 2 days ago, I noticed that when I accelerated in 2nd gear onwards, there is a weird clicking noise coming from the engine. The noise isn't there on idle or accelerating in 1st gear and if I rev the car while it is in neutral, the noise isn't there. It seems to only come when there is boost. I brought it back to my mechanic who did my turbo work and he took it for a drive and he just said it was normal for the turbo to make that sound as it is an indication of the turbo making boost. He was reving it pretty hard when he was driving so the noise isn't as noticable due to the loudness of the engine and exhuast. It is very noticable when you are accelerating and changing gears normally. I am not sure what it is but it sure wasn't there when I first got my car back after the rebuilt. The sound is that of a piece of flexible plastic against a bicycle wheel.
 

·
Registered
Joined
·
411 Posts
Speaking of HLA Noise...

Has anyone gone ahead and replaced their rocker arm rail to the modified/improved, larger oiling channel one?

Was it spendy?
Was it a difficult job?
Did it truely eliminate the clatter?
Did you replace everything or just the arm rail?

I don't have an especially noticeable problem, but I've got 112K on my '89 GT and I think i just might go ahead and freaking do this.
 

·
Registered
Joined
·
539 Posts
I've finally found where the clicking or fluttering noise was coming from. Brought it down to the place where I got my new turbo and they said I had an exhuast leak so all I have to do it find the leak somewhere near the manifold and hopefully it will be solved. No wonder my car felt really sluggish after I got it back.
 

·
Registered
Joined
·
1,994 Posts
Re: Speaking of HLA Noise...

Has anyone gone ahead and replaced their rocker arm rail to the modified/improved, larger oiling channel one?

im intrested too
 

·
Registered
Joined
·
291 Posts
sounds

had exhaust manifold sound most noticeable when cold a sort of rhymic " popping". pulled(easy) aluminum manifold cover and found that manifold bolt was totally missing. mounted bolt, problem noise solved.

another irregular clacking sound, more noticiable when cold. not waterpump, not alternator, but noticed that crank pulley had slight wobble when revved engine. turned out to be a wornout harmonic balancer. my car has 150k miles, so don't expect this sound with low mileage.
 
J

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Clicking sounds....

I'm familiar with the sound you're referring to ( sounds like a clicking noise ) . I have had to replace exhaust manifold studs on two occasions on my '91 Turbo GT because I failed to replace all the studs the first time. If you don't want this problem to recur, I suggest you buy and install all new exhaust manifold studs. I'm not sure if they get brittle from the turbo heat, or if I just got a bad batch during the manufacturing process, but replacing all is good preventive maintenance. Hope this bit of info will be helpful ....
 

·
Registered
Joined
·
96 Posts
Clicking Sounds

I have also had some clicking sounds occur when my engine is cold. I'm pretty sure it's a lifter. After the car warms up a bit the clicking goes away. I have a mechanic for a neighboor and he said that it would be ok as long as it kept getting oil but may need replacement down the road. Anyone else had problems with this clicking noise.
 
1 - 10 of 10 Posts
Top