Mazda MX-6 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
I have a 93 ls and when the car is on there seems to be a slight clicking coming from the engine...it's doesn't seem to be affecting anything, just clicks. I was just wondering if any of you guys know what's causing it, how I could get rid of it, and if it actually is damaging anything???
thanks guys!
 
G

·
Could be a few things. A valve would be my first guess or a lifter. Change your oil and run some that it apporiate. And see if that helps.
 
G

·
If its more like a click rather then a tapping (caused by valves) then you might just be hearing the injectors firing. The engine itself is very quiet so any extra noises are really brought out like those of the injectors. It is normal for this clicking from them. If you want to be certain, then take a length of 1/4" vac hose tubing and use it like a stethescope by sticking one end in your ear and probe the other end around the engine. If the click gets loud when you hold the end over by the injector then thats the culprit, if is gets louder when you hold it over the valve cover then it may indeed be the valves.
 

·
Registered
Joined
·
475 Posts
I have the same little clicking noise and a friend discovered the culprit to be a belt that was slightly off the tracks. Since it keeps goign around and around it produces a constant clicking noise. U may just want to make sure all your belts are fine...
 
G

·
the hla noise (that ticking noise) is not supposed to harm anything (from what i've heard), synthetic oil (mobil 1 tri-synthetic or redline) is known for quieting this down, worked for me, may take a few oil changes, may never go away, anyway, i've heard good oil change history is a big factor in how loud our engine will tick, so change your oil on time or early
 

·
Registered
Joined
·
24 Posts
you know i heard the lifter knocking (tapping sound) wasn't very bad either, even from a dealer mechaninc, so i bought the 93 mx6 despite the noise, well 2 months and 2 oil changes later the engine blew up after the taping got REALLY loud...so don't believe everything you hear...

...and now the kl-ze is making a clicking noise, that i believe is that belt problem or bearings in a pulley.
 
G

·
My hunch is that the cam gears are making the ticking type noise (very common).The only way to fix it is to replace the cam gears (expensive repair).No harm will be done if you don't replace them.
 

·
Registered
Joined
·
3,092 Posts
annoying? is it louder than when you bought the car? just wait til those HLAs fail. then clicking becomes knocking, knocking becomes banging... and then...the final BANG! aahhh memories... then you can build/ZE:D
 

·
Registered
Joined
·
24 Posts
i didn't actually get to the bang (i shot a rod out my block creating a hole the size of a sof ball on the civic i had prior to the mx) i just got the severe grinding and klacking, and decided the car wasn't gonna make it home...the shitty part is there is no reason for it to happen it just did...i had an oil change a week prior, and even the dealership i took it to afterwards said the engine was just out of oil, but the drain plug didn't leak or anything...i STILL don't get it, but yeah, GO ZE!!! i love mine! it was the one thing that made it okay
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top