Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
141 Posts
Discussion Starter #1
Here's a quick clip of my 1st gear pull. Clutch spins in 2nd when I get on it like that and causes me to pull off so my 0-60 mph isn't that good. This is at 8psi with boost control shut off. Whats a good clutch yall recommend? Something tested and proven. Im still using a stock clutch about 70k miles on it. I've been backing off the boost back down to the spring and I'm still spinning the clutch when I shift hard. Guess I can't expect too much out of the stock clutch. Thanks for any input

 

·
Registered
Joined
·
2,364 Posts
You mean slipping in 2nd gear, the clutch should be spinning between shifts

Personally I run Bully stage 3, 4 or 5 Clutches in all my cars. I never had any issues with ACT clutches (make sure it's sprung with needle bearings).
Clutches that never survived the 1200 km break in: Centerforce and exedy.
 

·
Registered
Joined
·
2,364 Posts
why does it look like you're idling with A/F's in the 11's?
 

·
Registered
Joined
·
141 Posts
Discussion Starter #4 (Edited)
according to the interwebs your o2 reading is not accurate at idle with a large cam profile and uneven intake velocities. Currently it idles in the 11s to keep the thing from surging like its lean. It still needs tuning on the ve table and spark advance. It doesn't like to idle close to stoich though so I've found. My injector dead time likely has something to do with it as the injector info sheet has been lost and it currently is just set to the standard 1ms setting. It idles with less than 2% injector duty cycle. I have room to pull fuel there just doesn't like it. Maybe its wrong though.
 
1 - 4 of 4 Posts
Top