Mazda MX-6 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Before I invest in a costly water pump repair, I just wanted to get you guy opinions. My wife's 94 mx6 v6 started to have power steering and high temp problems at the same time. Since the belts to the power steering pump and water pump are pretty related, I thought I would start there. I replaced the belt going round the water pump and now I am getting a coolant leak right from you know where (under the water pump). My question is, I didn't have a leak before I started. Could I have caused it by replacing the belt? Did I somehow "overtighten the belt"? The leaking starts about one minute after I start the engine. It's not a huge leak, but a "drip, drip type leak.
 

·
Registered
Joined
·
265 Posts
Sounds like the water pump. If you accidentally hit it or something while you were doing the belts, you may have caused the seal to break. There is a weep hole on the bottom of the pump that drips like you are describing when it is broken.

It's an involved job. You have to take off the timing belt to get to the Wpump. Replace the timing belt while you have it off.

Search for waterpump and timing belt to get some more specifics.

Sorry man.
 

·
Registered
Joined
·
355 Posts
ugghhhh

yeah,, its a PITA. I ran for a while with my pump leaking badly, but eventually (sooner than later i might add) you are going to have to have it replaced.

DO NOT let it overheat. Cut it off before it gets into the red.
 
1 - 3 of 3 Posts
Top