Mazda MX-6 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
OK, i've got my 97 v6 and there are a few problems and i would like outside input before i do anything.
problem 1. im burning oil, lots of it. now there is a hole in my downpipe that will be fixed very soon as soon as my OBX headers and downpipe come in from UPS, so that could be part of the casue of that.

2. my temp gauge is reading at 3/4 instead of 1/2 like it should be and it fluxuates from day to day sometimes its normal sometimes its not. im on my 2nd thermostate for the year as the first one was faulty and my water pump is practically new as well and im currently running a 50/50 mix. ive checked my fans and they run when they want to. Also is there a sort of performance radiator and fans that i can get?
idealy i would like my engine to run a little bit colder than normal so if im going to start replacing/ fixing compontents what can i do or buy to make evrything run cooler than it would normaly.
Any input is appreciated.
 

·
Registered
Joined
·
1,588 Posts
1. just because you're loosing oil does not necessarily mean you're burning it (does you car puff blue smoke on startup/takeoffs? then you might be). You might be loosing oil from (heres hoping you have a haynes manual or know what i'm talking about), your oil pressure sending unit, valve covers, into your sparkplug wells and/or our of the oil filter housing (there is a seal in the middle of it). Some of these leaks only occur while the motor is running and can be quite slow but steady while the oil pressure is up. So just because nothing shows on your driveway it doesn't mean you're not leaking.


2. Check the coolant temperature sensor. See if its within specs (found in haynes manual). Your car should have no problems keeping temperature esp. at this time of year in toronto...you don't need performance fans. Also make sure your fluid levels are topped up completely....not just in the reservoir but open the fillup cap thats on the motor on the passenger side (when the motor is cool)
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
yea i am puffing blue smoke thats how i knew i was burning oil not leaking it.
and all my fluids are topped up to recommended levels. ill check the coolant temp sensor tomorrow when i can get into a shop.
also i know i dont NEED the performance fans but i would still like them so can anyone recommend a good brand perf. fan?
 
1 - 3 of 3 Posts
Top