Mazda MX-6 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok, so my 93 mx6 has an issue with vibration...Its not really that noticable at city speeds (there are clunks from time to time) but when i get up to freeway speeds and remove the gas (coast in gear) it gets really bad. It feels like one of the CV shafts are about to come off and start beating the undercarage. While this is happening and i turn (either right or left, it doesnt matter) it goes away and the ride is smooth again! put it back in a straight line and it returns. So im thinking one of the CV's are worn out...but which one? anything else could cause this? Thanks guys
-Ryan
 

·
Registered
Joined
·
1,588 Posts
i'd say tie rods (most likely outer) or control arm bushings (maybe even the lower ball joint)

if it sounds that bad...diagnose and fix it right away you're putting yourself and others in danger at those speeds if something were to break

to find out where the problem is jack up the car on each side and find out where there is play in the chassis parts.

with the car jacked up (say driver side), jack it up high enough so the tire is off the ground

1- grab the wheel at 3 and 9 o'clock and wiggle it back and forth
2- repeat for 6 and 12

if there is little to no play check the passenger side...if there is a problem you will actually feel the wheel move (clunk) back and forth

once you know what side it is, look at the parts (mentioned above) to see which has play in it and replace
 
1 - 4 of 4 Posts
Top